#1  
Old 12th December 2005, 17:37
najohnston najohnston is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default ppp rx errors

Installed Mandriva free 2006. Connected to ISP by dialup 56k external modem. Can occasionaly receive web pages etc (may take several minutes to get google up) average transfer rate is about 40bytes/sec.

Looking at output of ifconfig i see almost as many rx packet errors as tx packets sent. Nothing in syslog etc that i can see as being wrong. No dropped packets either.

An eth0 interface is auto created for a firewire pci card, appart from that only the loopback interface and ppp0 are there.

Just read some details to check for default route of 0.0.0.0 offline, but not at my machine so can't try it out.

Hardware is ok (worked on mandrake 10.1 an hour before new install) works under win98 now. Even tried a complete re-install to see if it was a install problem.

Any ideas as to where the chain is going wrong?

neil
Reply With Quote
Sponsored Links
  #2  
Old 12th December 2005, 22:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Have you tried to configure your modem using the Mandriva Control Center?

Does a
Code:
ping -c2 www.google.com
work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th December 2005, 11:02
najohnston najohnston is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default ppp problems

tried various things since first post.

can ping say www.google.com but ping reports packets lost sust like ifconfig. Name resoultion takes a long time but once pings are up its about 150msec.

Actual packet loss is about 25% not the 100% i originaly thought

i tried nobsdcomp, noipdefault, defaultroute, novj, novjccomp, nopcomp, nodeflate, nomppc options in /etc/ppp/options but no success

i logged all ppp traiffic to file and used pppdump -p to look at it. It reported bad FCS on some packets, don't know why but this is the problem - which is why i turned of all compression etc (not that it was using it as the pppd log file was making sense even without the -d option)

It looks like something to do with ppp not networking or the server end.

resolv.conf and route -n all look correct.

One entry in the /var/log/messages file is interesting :

just after pppd Connect:@ ppp0 <--> /dev/pts/3 i get :
hal.dev: DEVNAME is not set

thats the only error visible.
Reply With Quote
  #4  
Old 13th December 2005, 11:04
najohnston najohnston is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default ppp proble

forgot to add :

Used kppp and mandriva network for defining the connection. no difference between them other than ones used chap and the other the other (forgotten its name pap?)
Reply With Quote
  #5  
Old 13th December 2005, 12:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What happens if you try to ping an IP address, e.g.
Code:
ping -c2  216.239.59.147
Can you post your /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 13th December 2005, 14:29
najohnston najohnston is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default ppp resolve.conf

Using the control centre setup and once logged on resolve.conf is :

nameserver 195.92.195.95 # pp temp entry
nameserver 195.92,195.94 # pp temp entry

route -n gives :
Destination Gateway Genmask Flags Metric Ref Use Iface
195.92.66.175 0.0.0.0 255.255.255.255 UH 50 0 0 ppp0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 195.92.66.175 0.0.0.0 UG 50 0 0 ppp0

ifconfig ppp0 when conntected and packet errors :
ppp0 Link encap:Point-to-Point Protocol
inet addr:81.78.210.126 P-t-P:195.92.66.175 Mask 255.255.255.255
UP POINTTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
Rx packets:23 errors:7 dropped:0 overruns:0 frame:0
Tx packets:33 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:1840 (1.7kiB) Tx vytes:1691 (1.6KiB)


excuse all spelling mistakes, not at machine so can't copy/paste

Somebody mentioned MTU size as a possible but i can't check it without re-installing the old OS (Its 1500 now but what was it with a working system). 1500 does sound big enough to me.

Output form pppdump had bad FCS on a packet of 55Bytes.

I'll try the ping c2 when i am at machine again.

chers
neil
Reply With Quote
  #7  
Old 13th December 2005, 14:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by najohnston
Somebody mentioned MTU size as a possible but i can't check it without re-installing the old OS (Its 1500 now but what was it with a working system). 1500 does sound big enough to me.
You could try 1492 instead of 1500.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 13th December 2005, 16:45
najohnston najohnston is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default ppp problem

will try different MTU size

Have noticed on a print out that a bad FCS on a recvd packet may of been caused by a short packet

- previous recvd packet ended something like
0a ff ff 50 f7 00 00 00 00 01 03 03 02

bad FCS packet ended
b7 bf ff ff 50 f7

have to look up ppp/ip packets and find out what the significance of ff ff 50 f7 is and if in ppp there should of been more bytes. Maybe something is dropping bytes so the FCS is calculated on the wrong thing (maybe even rubbish in the buffer.

pity i didn't print out more back packets to see if there is a pattern there.

ho hum - the beauty of source code

neil
Reply With Quote
  #9  
Old 13th December 2005, 22:14
najohnston najohnston is offline
Junior Member
 
Join Date: Dec 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default ppp rx errors

Not going to solve this. Rolled back to mandrake 10.1 and it works again. Can't spot any differnce in whats happening between the mandriva and mandrake.

Mandriva 2006 free uses ppp 2.4.3-9
Mandriva uses ppp-2.4.3-4
Mandrake 10.1 uses 2.4.2-7

pppd is now at 2.4.4 so i guess some bugs have been resolved.

Did try 2.4.2-7 on mandriva-2006 as well as ppp-2.4.3-4 but same problem so it may not be a pppd problem after all (as it works fine on mandrake 10.1).

The FCS failed packets are short according to the IP length, missing at least 9 bytes at the end - which is going to cause the bad FCS.

Maybe i'll continue looking for the solution. But for now i have to get a working connection back up.

Thanks for the advice, maybe these posting will of be of use to someone else as well.

cheers
neil
Reply With Quote
  #10  
Old 10th January 2006, 22:51
bruno.vernay bruno.vernay is offline
Junior Member
 
Join Date: Jan 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Same problem

Hello,
I have the same problem.
I have an error message : "couldn't find interface ppp0"
and "hal.dev: DEVNAME is not set" too
Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Several errors and ideas for features jmroth Feature Requests 16 6th March 2006 05:39
PHP Errors in the "WEB-FTP" module crudolphy General 9 27th December 2005 20:17
FC3 Perfect Installation Make Errors solderboy HOWTO-Related Questions 3 2nd October 2005 16:55
Perfect Fedora Core 4 install (GPG key errors) linuxfast HOWTO-Related Questions 2 16th September 2005 19:54
Postfix Errors? bolinux General 5 20th August 2005 16:06


All times are GMT +2. The time now is 02:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.