Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11th March 2008, 22:13
coolvik coolvik is offline
Junior Member
 
Join Date: Apr 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question Installing Yum in CentOS on a VPS

Hi,

I just found out that my VPS hasn't yum installed. So I found this guide to install it: http://wiki.centos.org/TipsAndTricks/BrokenVserver

After the step
Code:
rpm -Uvh *.rpm
I got quite many dependencies errors.
Code:
[root@bg yum]# rpm -Uvh *.rpm
warning: python-2.4.3-19.el5.i386.rpm: V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by python-2.4.3-19.el5.i386
        libcrypto.so.6 is needed by python-2.4.3-19.el5.i386
        libdb-4.3.so is needed by python-2.4.3-19.el5.i386
        libreadline.so.5 is needed by python-2.4.3-19.el5.i386
        libssl.so.6 is needed by python-2.4.3-19.el5.i386
        rtld(GNU_HASH) is needed by python-2.4.3-19.el5.i386
        libc.so.6(GLIBC_2.4) is needed by python-elementtree-1.2.6-5.i386
        rtld(GNU_HASH) is needed by python-elementtree-1.2.6-5.i386
        libc.so.6(GLIBC_2.4) is needed by python-sqlite-1.1.7-1.2.1.i386
        rtld(GNU_HASH) is needed by python-sqlite-1.1.7-1.2.1.i386
        m2crypto >= 0.16-5 is needed by python-urlgrabber-3.1.0-2.noarch
        libc.so.6(GLIBC_2.4) is needed by sqlite-3.3.6-2.i386
        libreadline.so.5 is needed by sqlite-3.3.6-2.i386
        rtld(GNU_HASH) is needed by sqlite-3.3.6-2.i386
        rpm >= 0:4.4.2 is needed by yum-3.0.5-1.el5.centos.5.noarch
        rpm-python is needed by yum-3.0.5-1.el5.centos.5.noarch
        yum-metadata-parser is needed by yum-3.0.5-1.el5.centos.5.noarch
[root@bg yum]#

Seems to me that the hosting company have installed a minimal CentOS.

Is there any way to use the rpm command to get all those dependent packages as well?


Regards,
Daniel
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuck on Centos Yum update fgaughan Installation/Configuration 6 20th September 2013 15:40
Problems with installation on openSUSE 10.2 douglaslopezt Installation/Configuration 3 24th August 2007 23:04
Problems Installing in CentOS 4.2 fresh JLChafardet Installation/Configuration 3 31st March 2006 22:36
Problem occurs after installing postfix into a VPS Guido64 Server Operation 3 27th March 2006 13:47
Problem installing on CentOS 4.2 bokko Installation/Configuration 4 1st March 2006 18:14


All times are GMT +2. The time now is 03:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.