Prev Previous Post   Next Post Next
  #1  
Old 7th March 2008, 23:44
Chad Chad is offline
Member
 
Join Date: Apr 2007
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ruby / FastCGI Problem

I tried to install my rails application. However it does not work
properly (the rails welcome screen's "About your application
environment" link gives a "Application error Rails application failed
to start properly" message), and the error log shows plenty of FastCGI
warnings and fcg incomplete header errors:


[Thu Mar 6 07:44:20 2008] [warn] FastCGI: (dynamic) server
"/home/username/public_html/jaspis/public/dispatch.fcgi" has failed
to remain running for 30 seconds given 3 attempts, its restart interval has
been backed off to 600 seconds
[Thu Mar 6 07:39:47 2008] [error] [client 91.120.172.159] FastCGI: incomplete
headers (0 bytes) received from server
"/home/username/public_html/jaspis/public/dispatch.fcgi"
[Thu Mar 6 07:39:47 2008] [warn] FastCGI: (dynamic) server
"/home/username/public_html/jaspis/public/dispatch.fcgi" has failed
to remain running for 30 seconds given 3 attempts, its restart interval has
been backed off to 600 seconds
[Thu Mar 6 07:39:47 2008] [error] [client 91.120.172.159] FastCGI: comm with
(dynamic) server
"/home/username/public_html/jaspis/public/dispatch.fcgi" aborted:
(first read) idle timeout (30 sec)



Code:
/usr/local/bin/ruby -v
ruby 1.8.5 (2006-08-25) [i686-linux]

whereis ruby          
ruby: /usr/bin/ruby /usr/lib/ruby /usr/local/bin/ruby /usr/local/lib/ruby /usr/local/ruby /usr/man/man1/ruby.1

./dispatch.fcgi
./dispatch.fcgi:21:in `require': no such file to load -- ./../config/environment (LoadError)
        from ./dispatch.fcgi:21
Code:
root@server [/home/user/public_html/dir]# ls -lh
total 68K
drwxr-xr-x  13 user user 4.0K Mar  5 04:29 ./
drwxr-x---   7 user nobody   4.0K Mar  6 10:49 ../
drwxr-xr-x   6 user user 4.0K Mar  4 08:28 app/
drwxr-xr-x   4 user user 4.0K Mar  6 10:33 config/
drwxr-xr-x   3 user user 4.0K Mar  4 08:56 db/
drwxr-xr-x   2 user user 4.0K Mar  4 08:28 doc/
drwxr-xr-x   3 user user 4.0K Mar  4 08:56 lib/
drwxr-xr-x   2 user user 4.0K Mar  4 08:28 log/
drwxr-xr-x   5 user user 4.0K Mar  6 10:43 public/
-rw-r--r--   1 user user  307 Mar  4 08:28 Rakefile
-rw-r--r--   1 user user 8.7K Mar  4 08:28 README
drwxr-xr-x   4 user user 4.0K Mar  4 08:28 script/
drwxr-xr-x   7 user user 4.0K Mar  4 08:28 test/
drwxrwxrwx   6 user user 4.0K Mar  4 08:28 tmp/
drwxr-xr-x   3 user user 4.0K Mar  4 08:28 vendor/
Code:
root@server [/home/user/public_html/dir/config]# ls -lh
total 32K
drwxr-xr-x   4 user user 4.0K Mar  6 10:33 ./
drwxr-xr-x  13 user user 4.0K Mar  5 04:29 ../
-rw-r--r--   1 user user 2.7K Mar  4 08:28 boot.rb
-rw-r--r--   1 user user  638 Mar  6 10:33 database.yml
-rw-r--r--   1 user user 2.8K Mar  6 04:31 environment.rb
drwxr-xr-x   2 user user 4.0K Mar  4 08:47 environments/
drwxr-xr-x   2 user user 4.0K Mar  4 08:28 initializers/
-rw-r--r--   1 user user 1.6K Mar  4 08:46 routes.rb




Files in the config directory have all -rw-r--r-- (644), subdirectories have
755, the files in the environments subdirectory all have 644 permissions.

Owner is username, group is username in all cases.

I have now changed the shebang line of dispatch.fcgi from:
#!/usr/bin/ruby to
#!/usr/local/bin/ruby
I also did this with the dispatch.rb and the dispatch.cgi

The issue continues and I'm finding it rather difficult to trace the immediate
cause of this fastcgi module issue. Your assistance is appreciated.



Specs:
Centos 5 / Cpanel 11 / PHP 5 / MYSQL 5
__________________
Talk Jesus Forums & Live Chat www.talkjesus.com
[ Awesome Facts of Jesus Christ: click here ]

Last edited by Chad; 7th March 2008 at 23:47.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Debian with Ruby on Rails and Apache 2 with FastCGI - Having Issues hayashi HOWTO-Related Questions 2 7th April 2007 03:49
Ruby on Rails Apache2 Fastcgi debian fnewtz HOWTO-Related Questions 1 30th July 2006 16:51
Ruby on Rails & FastCGI calande Feature Requests 2 11th May 2006 18:03


All times are GMT +2. The time now is 01:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.