#1  
Old 3rd March 2008, 22:36
mayhem mayhem is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default X dosnt start [solved]

Hi,
i installed the ubuntu 7.10 version, and im tryn to get gnome to work.
After "apt-get install gnome" i try to start it by "startx" i recive this error:

Code:
mayhem@zeroseven:~$ startx
xauth:  creating new authority file /home/mayhem/.serverauth.4928

X: cannot stat /etc/X11/X (No such file or directory), aborting.
giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
What to do?

Last edited by mayhem; 4th March 2008 at 18:05.
Reply With Quote
Sponsored Links
  #2  
Old 4th March 2008, 07:27
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Do you have the package xserver-xorg-core installed ? As the link to your Xorg is missing.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 4th March 2008, 13:40
mayhem mayhem is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No i havnt done that. I will do it now, thanks

mayEdit:
I did "sudo apt-get install xserver-xorg-core" and it installed everything, but it dosnt start now,
when i do "startx" this comes up:
Code:
mayhem@zeroseven:~$ startx
xauth: creating new authority file /home/mayhem/-serverauth.2345


X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8.3)
Current Operating System: Linux zeroseven.address.com 2.6.22-14-server #1 SMP Tue Feb 12 08:27:05 UTC 2008 i686
Build Date: 18 January 2008
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar  4 13:46:13 2008
(==) Using config file: "/etc/X11/xorg.conf"

Fatal server error:
No valid FontPath could be found.
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known prossesed) with 0 events remaining.
And the log file says:
Code:
mayhem@zeroseven:~$ cat /var/log/Xorg.0.log

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8.3)
Current Operating System: Linux zeroseven.address.com 2.6.22-14-server #1 SMP Tue Feb 12 08:27:05 UTC 2008 i686
Build Date: 18 January 2008
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar  4 13:46:13 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Generic Monitor"
(**) |   |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/fonts/X11/misc" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
        Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
        Entry deleted from font path.

Fatal server error:
No valid FontPath could be found.
(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
(WW) xf86OpenConsole: VT_GETSTATE failed: Bad file descriptor

Last edited by mayhem; 4th March 2008 at 14:05.
Reply With Quote
  #4  
Old 4th March 2008, 16:45
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

I think you need this as well xfonts-base
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 4th March 2008, 18:04
mayhem mayhem is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks, it worked
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to start vmware-server-console satimis Server Operation 2 25th November 2007 00:43
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 21:58
dns server error Hellbound General 7 2nd August 2007 09:18
Start stop script debian ColdDoT Server Operation 3 23rd April 2006 18:45
MYSQL Will NOT start.... Richard Server Operation 8 17th April 2006 10:54


All times are GMT +2. The time now is 19:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.