Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th February 2008, 10:36
maortega maortega is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postifx configuration problem, no route to host

I've successfully installed an Ubuntu Server 7.1 with ISPConfig as the hosting panel, i've set up a new site and was trying to install the PHPMotion platform...

Everything looks to be fine, but when i try to create a new account, it is supposed to send a confirmation email...

I think there's a problem with the postfix configuration... since my ISP has blocked port 25 i've changed the configuration to use port 26....

But i still can't send smails...

Here's the sudo netstat -tap result:
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN     15608/mysqld
tcp        0      0 *:www                   *:*                     LISTEN     4091/apache2
tcp        0      0 *:81                    *:*                     LISTEN     24647/ispconfig_htt
tcp        0      0 *:ftp                   *:*                     LISTEN     27937/proftpd: (acc
tcp        0      0 *:26                    *:*                     LISTEN     3830/master
tcp        0      0 *:https                 *:*                     LISTEN     4091/apache2
tcp6       0      0 *:imaps                 *:*                     LISTEN     13151/couriertcpd
tcp6       0      0 *:pop3s                 *:*                     LISTEN     13058/couriertcpd
tcp6       0      0 *:pop3                  *:*                     LISTEN     12991/couriertcpd
tcp6       0      0 *:imap2                 *:*                     LISTEN     13094/couriertcpd
tcp6       0      0 *:ssh                   *:*                     LISTEN     10385/sshd
tcp6       0      0 *:26                    *:*                     LISTEN     3830/master
tcp6       0    548 marksofthosting.com:ssh maortega:4185           ESTABLISHED3582/sshd: administ
And here is the sudo sendmail -bp result:
Code:
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
D1B8CCF8BC     1337 Thu Feb 28 03:00:31  www-data@marksofthosting.com
                   (connect to mx1.hotmail.com[65.54.244.8]: No route to host)
                                         mymail@hotmail.com

01D6FCF8C0     1337 Thu Feb 28 01:42:57  www-data@marksofthosting.com
                 (connect to mx3.hotmail.com[65.54.244.200]: No route to host)
                                         mymail@hotmail.com

-- 4 Kbytes in 2 Requests.
What do you recommend me to do now?

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 28th February 2008, 11:31
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

if your ISP has blocked port 25 outbound then your setup will never work, changing your local postfix to port 26 is not going to help you as the servers you are trying to send mail to are listening on port 25.

Why dont you use your ISP as a relayhost ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 29th February 2008, 22:04
maortega maortega is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Relay host

Thanks for the response, i'll search a how to on doing what suggested.

I'll come back to post the results...
Reply With Quote
  #4  
Old 1st March 2008, 17:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 2nd March 2008, 08:00
maortega maortega is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Thanks

Thanks for the link. I should try it and come back with the results.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig with postfix problem Chrisssssss General 30 20th January 2007 23:34
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
No access to public_html in user directories... sthompson Installation/Configuration 23 19th August 2006 16:53
SSL related problems senzapaura Installation/Configuration 45 25th March 2006 14:15
Problem getting from localhost on virtual host OnTheRun Installation/Configuration 2 5th January 2006 12:01


All times are GMT +2. The time now is 21:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.