Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Desktop Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th February 2008, 18:07
normanp normanp is offline
Member
 
Join Date: Dec 2007
Posts: 33
Thanks: 5
Thanked 1 Time in 1 Post
Default Frequency out of range (Ubu 7.10 Wks)

Having installed Ubuntu 7.10 workststion on several different machines (different hardware) I keep getting a strange common problem:
During boot up (the graphical section as Ubu starts services with a progress bar, before the logon screen appears) I get the monitor reporting frequency out of range. This disappears when the log on screen appears and then desktop/apps operate perfectly.

Is there a separate x configuration for the loading phase of boot up?
Thanks for any advice.
Reply With Quote
Sponsored Links
  #2  
Old 12th February 2008, 20:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Are you using TFT displays or monitors? TFT monitors might try to adjust themselves during the boot process, which maybe causes the message.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th February 2008, 13:56
normanp normanp is offline
Member
 
Join Date: Dec 2007
Posts: 33
Thanks: 5
Thanked 1 Time in 1 Post
Default

It's a TFT display. I think the message is up too long for the monitor to be adjusting itself. My feeling is that there must be some default X setting that applies during boot then gets set to a good value afterwards.
Reply With Quote
  #4  
Old 13th February 2008, 17:30
deate deate is offline
Junior Member
 
Join Date: Feb 2008
Posts: 10
Thanks: 3
Thanked 0 Times in 0 Posts
Default Frequency out of range

Just so you don't think you're alone, mine does this too, using ubuntu ultimate edition( Gutsy G 7.10) NEC accusync lcd 52V. A little irritating to have to keep pushing reset button, isn't it? Hope someone has soultion
Reply With Quote
  #5  
Old 13th February 2008, 17:36
deate deate is offline
Junior Member
 
Join Date: Feb 2008
Posts: 10
Thanks: 3
Thanked 0 Times in 0 Posts
Default Frequency out of range

Just a PS. it didn't do this on earlier versions, which were Fiesty Fawn based, just showed up with installation of Gutsy version(ultimate edition1.6) which indicates something in Gutsy causing problem
Reply With Quote
  #6  
Old 13th February 2008, 18:23
deate deate is offline
Junior Member
 
Join Date: Feb 2008
Posts: 10
Thanks: 3
Thanked 0 Times in 0 Posts
Default Frequency out of range

Whoops!!! Spoke too soon, forgot that I have Ububtu Studio 7.10 on another machine with samsung syncmaster 770tft, that does not have this problem...my bad...?maybe it's something with brand of monitors?
Reply With Quote
  #7  
Old 13th February 2008, 20:41
normanp normanp is offline
Member
 
Join Date: Dec 2007
Posts: 33
Thanks: 5
Thanked 1 Time in 1 Post
Default

My guess is that there is some default at this point - which some monitors like your Samsung can handle...?
Reply With Quote
  #8  
Old 13th February 2008, 23:04
o.meyer o.meyer is offline
Senior Member
 
Join Date: Aug 2007
Posts: 167
Thanks: 2
Thanked 24 Times in 23 Posts
Default

Hi,

please paste the content of your Xorg configuration.

Code:
cat /etc/X11/xorg.conf
Best regards,

Olli
Reply With Quote
  #9  
Old 14th February 2008, 01:27
deate deate is offline
Junior Member
 
Join Date: Feb 2008
Posts: 10
Thanks: 3
Thanked 0 Times in 0 Posts
Default frequency out of range

deate@deate-desktop:~$ cat /etc/X11/xorg.conf
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV43 [GeForce 6600]"
Driver "nvidia"
Busid "PCI:5:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "LCD52V"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV43 [GeForce 6600]"
Monitor "LCD52V"
Defaultdepth 24
SubSection "Display"
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
EndSection
deate@deate-desktop:~$
deate@deate-desktop:~$
I'm new to linux...is this what you wanted to see?
Reply With Quote
  #10  
Old 15th February 2008, 11:28
o.meyer o.meyer is offline
Senior Member
 
Join Date: Aug 2007
Posts: 167
Thanks: 2
Thanked 24 Times in 23 Posts
 
Default

Hi deate,

yes, that's what I wanted to see

Please make a backup of your xorg.conf ...

Code:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.orig
... and afterwards edit the section "Monitor" in the xorg.conf. Add a line for horizontal synchronization and a line for vertical refresh. If your LCD is connected analog, the value for vert.refresh is 75.0 (Hz) - if it is connected digital, the value should be 60.0 (Hz). The value for the horiz.sync. depends on your device (have a look at the manual).

The section should look like this (analog):

...

Code:
Section "Monitor"
Identifier "LCD52V"
Option "DPMS"
HorizSync       30.0 - 75.0
VertRefresh     75.0
EndSection
...

Or like this (digital):

...

Code:
Section "Monitor"
Identifier "LCD52V"
Option "DPMS"
HorizSync       30.0 - 75.0
VertRefresh     60.0
EndSection
...

Save the file, reboot your system and look what happens

Best regards,

Olli

Last edited by o.meyer; 15th February 2008 at 11:30.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Problem (Ubu Server 7.10) normanp Server Operation 19 13th February 2008 22:30
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38


All times are GMT +2. The time now is 09:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.