Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Programming/Scripts

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st January 2006, 16:05
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default Perl error message

Hey can anyone help me

Quote:
/etc/cron.weekly/man-db:
mandb: can't set the locale; make sure $LC_* and $LANG are correct
/etc/cron.weekly/sysklogd:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_IE:en_US:en_GB:en",
LC_ALL = "<locale>",
LANG = "en_IE@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Can anyone help

O keep getting this email every day

Last edited by namit; 1st January 2006 at 16:09.
Reply With Quote
Sponsored Links
  #2  
Old 1st January 2006, 16:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Which distribution do you use? On Debian you can install the missing locales by running
Code:
dpkg-reconfigure locales
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st January 2006, 17:09
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ok did that but when ran it agina i got this message

Generating locales...
en_IE.ISO-8859-15@euro... done
en_IE.ISO-8859-1... done
Generation complete.
mailman:/# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_IE:en_US:en_GB:en",
LC_ALL = "<locale>",
LANG = "en_IE@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory


Verstion
This is perl, v5.8.4 built for i386-linux-thread-multi

yes am using debian

I did loose all my users so this may because of this
Reply With Quote
  #4  
Old 1st January 2006, 18:49
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,988
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Have you run "dpkg-reconfigure locales" as root user?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st January 2006, 19:07
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

yes i have
Reply With Quote
  #6  
Old 1st January 2006, 19:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

This seems to be the same error I describe in my Xen tutorial: http://www.howtoforge.com/perfect_xe...ian_ubuntu_p4:

Quote:
Now we set up our locales. If we do not do this now, we will see some ugly warnings during base-config like these:

Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_DE:en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
They are not serious, but ugly... So we run

Code:
apt-get install localeconf
Select locales to install (e.g. en_US ISO-8859-1) and select the standard locale (e.g. en_US).

You will be asked a few questions:

Code:
Manage locale configuration files with debconf? <-- Yes
Environment settings that should override the default locale: <-- do not select anything
Replace existing locale configuration files? <-- Yes
Default system locale: <-- e.g. en_US ISO-8859-1
So I guess running
Code:
apt-get install localeconf
might be a good idea.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 1st January 2006, 19:30
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

na that did not work still same old same old

just says
"and lot lot more errors"
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Its not that its not ugly its just that i keep getting this email from cron saying the error message see above
Reply With Quote
  #8  
Old 4th January 2006, 03:56
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

went into /etc/envirement and set all values to ""

just types in
LC_CTYPE = ""

etc etc etc

Thanks
Reply With Quote
  #9  
Old 10th February 2006, 03:26
hammeraus001 hammeraus001 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Possible Solution

I just hasd the same issue and have found an easy solution. It's all in the error message, especially the line:

LANGUAGE = "en_DE:en_US:en_GB:en",

When you either "apt-get install locales" or "dpkg-reconfigure locales", you are asked to select the required locales from a large list.

I went through and selected the ones that I needed. The error still appeared. I then redid it and made sure that the languages listed were the ones I selected, which would be "en_DE", "en_US" and "en_GB" in your case. Once I did that the errors vanished.
Reply With Quote
  #10  
Old 18th April 2007, 08:28
charles_elwood charles_elwood is offline
Junior Member
 
Join Date: Apr 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It's also useful to check you have language-pack-?? installed, as that provides the actual locales. English speakers will most likely want language-pack-en.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PERL scripts in Mozilla Browser Deepthi Server Operation 3 20th December 2005 15:01
Installing Perl modules fernando Installation/Configuration 1 10th May 2005 21:16


All times are GMT +2. The time now is 09:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.