#1  
Old 14th January 2008, 18:14
joephus joephus is offline
Junior Member
 
Join Date: Jan 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Bind Problem

I'm trying to setup bind and everything seems to be working fine except for the fact that none of my zones are propagating. I'm running Bind 9.3.3RC2 in a chroot configuration. The server starts up fine, I can run rndc just fine and the status switch returns the following

Quote:
Originally Posted by rndc
number of zones: 2
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/1000
tcp clients: 0/100
server is up and running
I have two domains that I'm trying to host on this DNS server, lets call them domain1.com and domain2.com. My registrar has an ns1.domain1.com, that is resolving to the world, and it is listed as the primary DNS server for domain1.com and domain2.com. When I do an nslookup from any server other than my DNS box, both domain1 and domain2 fail to resolve. However, when I use my DNS server to lookup both domains they work just find. It is like I just can't figure out why propagation isn't working. The contents of my named.conf are listed below (private information replaced).

TIA for any help!

Quote:
Originally Posted by named.conf
key "rndckey" {
algorithm hmac-md5;
secret "xxxxxxxxxxxxxxxxxxxxxxxx";
};

controls {
inet 127.0.0.1 allow { 127.0.0.1; } keys { "rndckey"; };
inet xx.xx.xxx.xxx allow { xx.xx.xxx.208/29; } keys { "rndckey"; };
};

options {
directory "/var/named";
pid-file "/var/run/named/named.pid";

recursion yes;

allow-recursion {
127.0.0.1;
xx.xx.xxx.208/29;
};

// these are the opendns servers (optional)
forwarders {
208.67.222.222;
208.67.220.220;
};

listen-on {
127.0.0.1;
xx.xx.xxx.xxx;
};

query-source address * port 53;

// so people can't try to guess what version you're running
version "REFUSED";

allow-query {
127.0.0.1;
xx.xx.xxx.208/29;
};
};

server xx.xx.xxx.xxx{
keys { rndckey; };
};

zone "." IN {
type hint;
file "named.ca";
};

zone "domain1.com" IN {
type master;
file "data/domain1.com.zone";
allow-update { none; };
allow-transfer { none; };
};

zone "domain2.com" IN {
type master;
file "data/domain2.com.zone";
allow-update { none; };
allow-transfer { none; };
};

Last edited by joephus; 15th January 2008 at 03:47.
Reply With Quote
Sponsored Links
  #2  
Old 14th January 2008, 19:29
joephus joephus is offline
Junior Member
 
Join Date: Jan 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Fixed

Just in case anyone reads this and runs into the same issue, I figured out the problem shortly after posting this. I was not allowing queries from any other DNS servers. In the options section I had allow-query set for only my local network, so no other networks could query for my hosted zones. In the zone statements in named.conf I added the following line:

allow-query { any;};

Problem fixed.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Problem on restart bind9 satimis Server Operation 6 30th October 2007 02:01
saslauthd problem: bind: Address already in use fitti70 Server Operation 4 14th May 2007 21:51
Problem with BIND and ISPConfigs's DNS Manager Nejko Installation/Configuration 66 22nd April 2006 20:47
Bind-Chroot-Howto (Debian) spaz HOWTO-Related Questions 5 9th March 2006 14:50


All times are GMT +2. The time now is 02:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.