Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th January 2008, 00:34
hgrimberg01 hgrimberg01 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default Mail from Postfix Sends but Dovecot wont recieve w/ ispconfig

I set up ispconfig as usual and got everything working except one thing.
I can't recieve emails from any domain, i can send them just find, not block thanks to SPF ,but i cant recieve. When send emails from my gmail to my server for a test this is what i get in return(domain names changed for privacy).
blahblahblah.info = server/ispconfig name
server1 = ispconfig hostname
123rg.com = intended mail target residing on server


Final-Recipient: rfc822; hgrimberg@server1.blahblahblah.info
Original-Recipient: rfc822;hgrimberg@123rg.com
Action: failed
Status: 5.4.4
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
for name=server1.blahblahblah.info type=A: Host found but no data
record of requested type

Seems like a dns error, but all other dns services, any suggestions?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 9th January 2008, 17:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please make sure that the DNS record exists:
Code:
dig server1.blahblahblah.info
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th January 2008, 05:47
hgrimberg01 hgrimberg01 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default Still Doesnt Work

Does not work, record exists now. Changed it, now i get this returned.

This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

hgrimberg@howardgrimberg.com

Message will be retried for 2 more day(s)

Technical details of temporary failure:
TEMP_FAILURE: Could not initiate SMTP conversation with any hosts:
[server1.europeandelightsserver.info.howardgrimberg .com. (10): Destination address required]

----- Message header follows -----

Received: by 10.82.157.6 with SMTP id f6mr1877472bue.1.1199910808575;
Wed, 09 Jan 2008 12:33:28 -0800 (PST)
Received: by 10.82.117.13 with HTTP; Wed, 9 Jan 2008 12:33:28 -0800 (PST)
Message-ID: <e178f2210801091233o78bab1a4nfcad694eccea3718@mail .gmail.com>
Date: Wed, 9 Jan 2008 14:33:28 -0600
From: "Howard Grimberg" <hgrimberg01@gmail.com>
To: hgrimberg@howardgrimberg.com
Subject: Re: Hellooooo
In-Reply-To: <da4cf9dcf24425b2d1cbd0ca152f3c02@localhost>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_Part_47394_13834902.1199910808572"
References: <da4cf9dcf24425b2d1cbd0ca152f3c02@localhost>

Last edited by hgrimberg01; 11th January 2008 at 05:56. Reason: Added Error
Reply With Quote
  #4  
Old 11th January 2008, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Code:
mh1:~# dig mx howardgrimberg.com

; <<>> DiG 9.3.4 <<>> mx howardgrimberg.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58602
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;howardgrimberg.com.            IN      MX

;; ANSWER SECTION:
howardgrimberg.com.     86400   IN      MX      5 europeandelightsserver.info.howardgrimberg.com.

;; Query time: 371 msec
;; SERVER: 213.191.92.84#53(213.191.92.84)
;; WHEN: Fri Jan 11 12:56:50 2008
;; MSG SIZE  rcvd: 80

mh1:~# dig europeandelightsserver.info.howardgrimberg.com

; <<>> DiG 9.3.4 <<>> europeandelightsserver.info.howardgrimberg.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 17450
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;europeandelightsserver.info.howardgrimberg.com.        IN A

;; AUTHORITY SECTION:
howardgrimberg.com.     10800   IN      SOA     ns1.europeandelightsserver.info. admin.howardgrimberg.com. 2008010814 28800 7200 604800 86400

;; Query time: 166 msec
;; SERVER: 213.191.92.84#53(213.191.92.84)
;; WHEN: Fri Jan 11 12:56:59 2008
;; MSG SIZE  rcvd: 137

mh1:~#
Your MX record points to europeandelightsserver.info.howardgrimberg.com, but europeandelightsserver.info.howardgrimberg.com doesn't exist. Please create an A record for it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th January 2008, 01:53
hgrimberg01 hgrimberg01 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Exists still getting same error.

here is the breakdown of my zones

europeandelightsserver.info
---------------------------------------
europeandelightsserver.info-A-64.151.6.117
ns1.europeandelightsserver.info-A-64.151.6.117
ns2.europeandelightsserver.info-A-64.151.6.117
server1.europeandelightsserver.info-A-64.151.6.117
ns1.europeandelightsserver.info-NS
ns2.europeandelightsserver.info-NS
europeandelightsserver.info-NS
www.europeandelightsserver.info - CAN(alias) - europeandelightsserver.info
No MX



howardgrimberg.com
----------------------------------
howardgrimberg.com - A - 64.151.6.117
www.howardgrimberg.com - A - 64.151.6.117
howard....com - ns1.europeandelightsserver.info.-NS
howard....com - ns2.europeandelightsserver.info.-NS
howard....com - europeandelightsserver.info - MX - 1
+SPF


Hope This Helps
Reply With Quote
  #6  
Old 12th January 2008, 17:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Code:
mh1:~# dig mx howardgrimberg.com

; <<>> DiG 9.3.4 <<>> mx howardgrimberg.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37052
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;howardgrimberg.com.            IN      MX

;; ANSWER SECTION:
howardgrimberg.com.     86400   IN      MX      1 europeandelightsserver.info.howardgrimberg.com.

;; Query time: 358 msec
;; SERVER: 213.191.92.84#53(213.191.92.84)
;; WHEN: Sat Jan 12 17:50:02 2008
;; MSG SIZE  rcvd: 80

mh1:~# dig  europeandelightsserver.info.howardgrimberg.com

; <<>> DiG 9.3.4 <<>> europeandelightsserver.info.howardgrimberg.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 49512
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;europeandelightsserver.info.howardgrimberg.com.        IN A

;; AUTHORITY SECTION:
howardgrimberg.com.     10800   IN      SOA     ns1.europeandelightsserver.info. admin.howardgrimberg.com. 2008010820 28800 7200 604800 86400

;; Query time: 204 msec
;; SERVER: 213.191.92.84#53(213.191.92.84)
;; WHEN: Sat Jan 12 17:50:10 2008
;; MSG SIZE  rcvd: 137

mh1:~#
Now europeandelightsserver.info.howardgrimberg.com doesn't exist...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
postfix ISPconfig problem matehortua Installation/Configuration 8 3rd September 2006 17:03
Mandriva with ISPConfig for Postfix sent mail to Yahoo & Hotmail lexcomputer Installation/Configuration 9 24th September 2005 17:24


All times are GMT +2. The time now is 00:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.