Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd January 2008, 14:26
samoand samoand is offline
Junior Member
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default dovecot problem - help please!

Greetings! I'm trying to configure dovecot on CentOS5.1, and here's where I'm hitting a wall. There are 2 machines: Windows and CentOS
1. I can telnet from CentOS machine to itself using either domain name or ip on port 110 and read all email, no problem. However, I can't do the same from the Windows machine.
2. Probably related to "1", but with a twist. I can't connect from Outlook client; "Test Account Settings" comes back with "Outlook cannot connect to your incoming (POP3) email server". However, test e-mail message from Outlook makes it to the test account and is viewable locally on the CentOS machine. In fact, it's viewable if I telnet to CentOS machine from itself on 110.

Closest setting in dovecot.conf that I found might be a suspect was "listen", it's currently set to default
listen = [::]
I tried to play with it and change it to all variables that would come to mind (ip, domain name, mail server name and combinations thereof) - without any result.
Any thoughts regarding the situation? Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 3rd January 2008, 14:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What are the outputs of
Code:
netstat -tap
and
Code:
iptables -L
? Did you disable SELinux?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th January 2008, 09:25
samoand samoand is offline
Junior Member
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Got it.
It was "listen" directive in dovecot.conf, nonetheless.
Replaced default "[::]" with "*" and everything worked. Apparently [::], while tuned to handle IPv6 interfaces, is less reliable for IPv4. My second mistake was trying to play with combinations of domain names and ip-s on that line: it doesn't like multiple entries.
Thanks!

Last edited by samoand; 6th January 2008 at 12:39.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
mail problems with imap Compadre Installation/Configuration 2 6th March 2008 10:54
Problem with uebimiau + dovecot tr4d3r General 5 28th August 2007 10:08
postfix + dovecot + postfixadmin - problem with quota kosta Server Operation 3 24th August 2007 22:08
Suse Postfix + Dovecot + ISP Config + smtp Auth; recieving problem! fatum112 HOWTO-Related Questions 2 15th January 2006 19:03


All times are GMT +2. The time now is 08:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.