Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th January 2007, 07:35
wiremeister wiremeister is offline
Junior Member
 
Join Date: Sep 2006
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Default GoDaddy DNS How To and ISPConfig

Hello Everyone,

Have a problem getting to our very own nameservers. Followed the Perfect Setup for Mandriva 2007, installed ISPConfig, and have read Traditional DNS HowTo, and How to run your own nameservers with ISPConfig and Go Daddy (also our registrar).

When we have both our own nameservers, and Park servers at GoDaddy in our nameserver record, we are able to access all of our websites. Delete the Park nameservers, and leave just our own NS3 and NS4 servers, and the entirety of the net seems to lose us completely. Using Dig, we can access less and less over time. At first, we can get a good result with all sites. Later, Dig cannot even locate NS3 and NS4. NS3 and NS4 are also set up at GoDaddy as our Hosts. GoDaddy has suggested there may be a problem with server configuration, as DNS appears to be correct on thier end. Comcast Business services (cable modem with 5 IP'S) has no clue, and I'm losing hair again...... (Not a lot left here!)

Would anyone have an idea why we cannot seem to transfer to our own nameservers after having followed all of Falko's good advice? We're new at this, and after three weeks of playing and searching, are totally lost right now.

Below is the readout of a dig to our IP:

; <<>> DiG 9.3.2 <<>> @74.92.214.65 any sheltiehosting.net
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63915
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 3

;; QUESTION SECTION:
;sheltiehosting.net. IN ANY

;; ANSWER SECTION:
sheltiehosting.net. 86400 IN SOA ns3.sheltiehosting.net. webmaster.sheltiehosting.net. 2007010305 28800 7200 604800 86400
sheltiehosting.net. 86400 IN NS ns4.sheltiehosting.net.
sheltiehosting.net. 86400 IN NS ns3.sheltiehosting.net.
sheltiehosting.net. 86400 IN MX 10 mail.sheltiehosting.net.
sheltiehosting.net. 86400 IN A 74.92.214.65

;; ADDITIONAL SECTION:
ns3.sheltiehosting.net. 86400 IN A 74.92.214.65
ns4.sheltiehosting.net. 86400 IN A 74.92.214.66
mail.sheltiehosting.net. 86400 IN A 74.92.214.65

;; Query time: 0 msec
;; SERVER: 74.92.214.65#53(74.92.214.65)
;; WHEN: Wed Jan 3 23:19:39 2007
;; MSG SIZE rcvd: 203

And again:

; <<>> DiG 9.3.2 <<>> @74.92.214.65 any www.sheltiehosting.net
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8687
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;www.sheltiehosting.net. IN ANY

;; ANSWER SECTION:
www.sheltiehosting.net. 86400 IN A 74.92.214.65

;; AUTHORITY SECTION:
sheltiehosting.net. 86400 IN NS ns3.sheltiehosting.net.
sheltiehosting.net. 86400 IN NS ns4.sheltiehosting.net.

;; ADDITIONAL SECTION:
ns3.sheltiehosting.net. 86400 IN A 74.92.214.65
ns4.sheltiehosting.net. 86400 IN A 74.92.214.66

;; Query time: 0 msec
;; SERVER: 74.92.214.65#53(74.92.214.65)
;; WHEN: Wed Jan 3 23:26:29 2007
;; MSG SIZE rcvd: 124

And our primary zone file (Which I THINK is correct..... ):

$TTL 86400
@ IN SOA ns3.sheltiehosting.net. webmaster.sheltiehosting.net. (
2007010305 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS ns3.sheltiehosting.net. ; Inet Address of name server 1
NS ns4.sheltiehosting.net. ; Inet Address of name server 2
;

MX 10 mail.sheltiehosting.net.

sheltiehosting.net. A 74.92.214.65
mail A 74.92.214.65
www A 74.92.214.65
ns3 A 74.92.214.65
ns4 A 74.92.214.66

ftp CNAME www.

ns3.sheltiehosting.net. TXT "v=spf1 ip4:74.92.214.65 ip4:74.92.214.66 ip4:74.92.214.67 ip4:74.92.214.68 ip4:74.92.214.69 a mx ptr include:yes ~all"
mail.sheltiehosting.net. TXT "v=spf1 ip4:74.92.214.65 ip4:74.92.214.66 ip4:74.92.214.67 ip4:74.92.214.68 ip4:74.92.214.69 a mx ptr include:yes ~all"

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;

Any ideas that my one brain cell that's left can absorb?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 5th January 2007, 15:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I'm getting this right now:

Code:
mh1:~# dig sheltiehosting.net

; <<>> DiG 9.2.1 <<>> sheltiehosting.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5225
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;sheltiehosting.net.            IN      A

;; ANSWER SECTION:
sheltiehosting.net.     3600    IN      A       68.178.232.100

;; Query time: 1414 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Fri Jan  5 15:40:34 2007
;; MSG SIZE  rcvd: 52

mh1:~# dig ns sheltiehosting.net

; <<>> DiG 9.2.1 <<>> ns sheltiehosting.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21365
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;sheltiehosting.net.            IN      NS

;; ANSWER SECTION:
sheltiehosting.net.     3594    IN      NS      PARK11.SECURESERVER.net.
sheltiehosting.net.     3594    IN      NS      PARK12.SECURESERVER.net.

;; Query time: 2 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Fri Jan  5 15:40:40 2007
;; MSG SIZE  rcvd: 91
so I guess you have switched back to the GoDaddy nameservers?

I think the problem could be with glue records: http://en.wikipedia.org/wiki/Dns#Cir...d_glue_records
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th January 2007, 16:31
wiremeister wiremeister is offline
Junior Member
 
Join Date: Sep 2006
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi Falko. Thanks for your response.

Yes. Switched back to the park servers late last night. I've updated dns at GoDaddy to resemble the How To once again. A dig in an hour or two should yield a better result. .com and .org can also be used for dig. Have not deleted the park servers from those two.

I can understand the concept of the glue record (though this is the first I have heard of such a thing), but how does it need to be formatted in order to avoid the circle? I am assuming that this needs to be part of the zone like an A or MX record. Or a change to an existing A record?

Also attempting to figure out why any website on the server can only be seen locally for some reason. Outside of Comcast, or outside our immediate area, all requests for any website on the server time out in all browsers. An interesting twist is that requesting a site's https page will contact the appropriate page without a problem, but using normal http times out????? Is this related to the glue record issue?

Yep, we're definately new to linux and servers in general, but we're trying hard. Lot's of confusion on dns out there! Thanks very much for your time, and all of your good advice!


(About 8 hours later)...

Spent some time on the phone with GoDaddy. They do have some folks there that are fairly savvy with dns that are also willing to work with someone whether using Linux or Windows. Nice to find that in a live body to talk to. We have moved the domain back to the parked servers to allow Verisign to update back to them to clear the current problem (glue record). The procedure seems to have changed by a small amount from the How To regarding DNS and GoDaddy just as thier interface has changed. We should know for certain about that in another 4 days or so after updating and distribution.

If all goes well, and the changes I mentioned have in fact changed (according to my understanding now) I'll update this for everyone to see. It's much, much easier to create the chicken and the egg problem than one would think..... More later, and thanks Falko for filling in that one piece of information (glue record) that is not talked about much at all.

Last edited by wiremeister; 6th January 2007 at 01:32.
Reply With Quote
  #4  
Old 6th January 2007, 15:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by wiremeister
If all goes well, and the changes I mentioned have in fact changed (according to my understanding now) I'll update this for everyone to see.
Yes, please report back.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th January 2007, 02:59
wiremeister wiremeister is offline
Junior Member
 
Join Date: Sep 2006
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Default

There has been one change at GoDaddy in regards to registering a name server. There is no need to change A records, or place your name server in the nameserver record with the park servers. Instead, fill out the information in the Host Summary. This will ask you for both the FQDN and IP of the server. You would then shortly recieve an email from GoDaddy that a new name server has been registered. Once the new information has been allowed to propagate, remove the park servers from the Name Server record, and replace with your newly registered name servers. That's it. No other changes required.

Which brings me to a newly discovered problem. Using the wonderful tools at dnsstuff.com, I've discovered that our name servers (ns3 and ns4.sheltiehosting.net) are not responding to dns queries. Using DNS Report, DNS Timing, and DNS Lookup, all goes well until the final referral to our ns3 and ns4 servers. Then everything stops. No information is forthcoming from our servers.

Looking at our named.conf files, we appear to be set up as a caching only name server. Not authorative. Could this be why our servers are not responding? Both servers can be pinged, and do respond to dig @ queries (glue records also appear in the Additional section).

Last edited by wiremeister; 8th January 2007 at 03:23.
Reply With Quote
  #6  
Old 8th January 2007, 23:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by wiremeister
and do respond to dig @ queries (glue records also appear in the Additional section).
Do you use
Code:
dig @ip_address blabla
or
Code:
dig @ns4.sheltiehosting.net blabla
?
Try both. Do they give different results?

What's in your named.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.