#1  
Old 2nd January 2007, 03:18
clabrown clabrown is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Default ISPConfig install error

I believe i completed the "Perfect" Ubuntu Server setup HowTo and followed that with the ISPConfig Howto. There were problems with unstated details like development packages I needed to install which were not explicitly mentioned but eventually the install seemed to continue almost to the end with the following information, something about a password of "YES" seems to start the problem. After this I can not log into ISPConfig with "admin" "admin". Any Ideas? I think my root password, which contained the characters "!@#$" may have conflicted with the shell script. Any Ideas how I can continue from here, or do I need to reformat and start over? Thanks.

Connected successfully to MySQL server
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
no crontab for root
Restarting some services...
* Stopping Postfix Mail Transport Agent postfix [ ok ]
* Starting Postfix Mail Transport Agent postfix [ ok ]
* Stopping ftp server proftpd [ ok ]
* Starting ftp server proftpd - IPv6 getaddrinfo 'ubs01.granitepost.com' error: Name or service not known
[ ok ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Please direct your browser to

https://ubs01.granitepost.com:81

and log in:
Username: admin
Password: admin
Reply With Quote
Sponsored Links
  #2  
Old 2nd January 2007, 13:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Did you create a database manually in MySQL that you used for the ISPConfig installation? Does your mysql root password contains special chars?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd January 2007, 15:35
clabrown clabrown is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Default

No I did not manually create any database. I was following the ISPConfig installation instructions and I don't think there was a step to manually create any database.

My MySQL root password is the same root password that I mentioned below. It contains the characters "!@#$".

Is the MySQL root user not the same root user of the whole machine?

Thanks, Cla.
Reply With Quote
  #4  
Old 2nd January 2007, 19:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by clabrown
My MySQL root password is the same root password that I mentioned below. It contains the characters "!@#$".
That's the problem. It must not contain special characters. Please change it and delete /root/ispconfig and /home/admispconfig, then install ISPConfig again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd January 2007, 19:20
clabrown clabrown is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Closer perhaps, but still no joy.

It gets further now, it does not have an error connecting or accessing the MySQL server. It still shows the PHP error in line 47 of /root/ispconfig/scripts/lib/config.inc.php

as directed ..

I erased the two directories.

I believe I changed the MySQL root password to something with only letters and numbers. It seems that there are 2 users or passwords that had to be changed, one without and one with the host name specified, similar to the following from the "perfect ubuntu setup" howto:

mysqladmin -u root password yourrootsqlpassword
mysqladmin -h server1.example.com -u root password yourrootsqlpassword

Now the ISPConfig install proceeds without apparent error right to the end where it has a PHP error in line 47. When I try to login to ISPConfig with Admin Admin it tells me "ERROR 101: wrong username or password". Here is a copy from the last of the install showing the error:


Connected successfully to MySQL server
Es ist schon eine Datenbank mit dem Namen db_ispconfig vorhanden!
Restarting some services...
* Stopping Postfix Mail Transport Agent postfix [ ok ]
* Starting Postfix Mail Transport Agent postfix [ ok ]
* Stopping ftp server proftpd [ ok ]
* Starting ftp server proftpd - IPv6 getaddrinfo 'ubs01.granitepost.com' error: Name or service not known
[ ok ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!FreshClam is already running!
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Please direct your browser to

https://ubs01.granitepost.com:81

and log in:
Username: admin
Password: admin

root@ubs01:~/install_ispconfig#

Thanks again for your help.
Reply With Quote
  #6  
Old 4th January 2007, 13:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Have you deleted the ISPConfig mysql database too before you reinstalled. If there is a mysql database with the same name that you entered in the ISPConfig installer, the setup will fail.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ispconfig Install error "lex.ssl_expr_yy.c:1901: error:" galmiche Installation/Configuration 1 30th December 2006 12:44
64-bit Debian 3.1 Install Issue naruto Installation/Configuration 14 5th September 2006 05:12
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! xinefnarg Installation/Configuration 2 28th March 2006 17:45
Error install xrtc Installation/Configuration 1 23rd March 2006 20:27
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 19:07


All times are GMT +2. The time now is 03:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.