Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th December 2006, 13:20
maYer maYer is offline
Junior Member
 
Join Date: Oct 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Database is inconsistendt / broken ?

After updating to the current stable version ( or even before ),
some customers have user to in there User-list, which belong to other accounts.

After checking the database i could not really see, what happen. First of all i need to state some questions :

isp_nodes :
where does user_id belong to ? isp_web / isp_kunde ?
somehow all numbers are messed up here

where is parent pointing to ?


Problems

Some users are not able to add any new users, they always get a "user already exists" ( me too).
I have this problem since iam using ISPconfig, so its nothing about the new version.

Some users suddenly have other users in their userlist, whcih belong to other accounts. They cannot administrate that users, even me as useradmin is not able. Concerning to the docid, i cant find that tree in isp_nodes

Thank you for any help
Reply With Quote
Sponsored Links
  #2  
Old 15th December 2006, 19:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Quote:
Originally Posted by maYer
isp_nodes :
where does user_id belong to ? isp_web / isp_kunde ?
somehow all numbers are messed up here
userid points to the table sys_user

Quote:
where is parent pointing to ?
parent is pointing to tree_id in the smae table.


Quote:
Problems

Some users are not able to add any new users, they always get a "user already exists" ( me too).
I have this problem since iam using ISPconfig, so its nothing about the new version.
Have you emptied all recycle bin's? There is a recycle bin for the admin and every reseller.

Quote:
Some users suddenly have other users in their userlist, whcih belong to other accounts. They cannot administrate that users, even me as useradmin is not able. Concerning to the docid, i cant find that tree in isp_nodes
the doc_id is nit connected to tree id.

doc_id in isp_isp_ user is connected to doc_id in isp_nodes, doctype_id in isp_isp_user is connected to doctype_id in isp_nodes. Its the same with isp_isp_web. isp_isp_user and isp_isp_web are connected trough the table isp_dep, where the child_* ID's are connected to isp_isp_user and the parent_* ID's are connected to isp_isp_web.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th December 2006, 10:58
maYer maYer is offline
Junior Member
 
Join Date: Oct 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello!

No it has absolutely nothing to do with the recycle bin..it`s empty..

So where could the problem then come from?. its not important which name i type in for the username, every name is in "use". The "maximum user" limit is set to 50, 13 are in use, no no reasons here.

What could be the problem in the part, that the user is shown at the wrong place ?

thank you a lot
Reply With Quote
  #4  
Old 16th December 2006, 12:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Please make sure the users you try to create don't already exist in /home/admispconfig/ispconfig/users. This file contains all users that existed on the system when you instaled ISPConfig to make sure that you don't create a second user with an existing username.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th December 2006, 13:40
maYer maYer is offline
Junior Member
 
Join Date: Oct 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It`s quite impossible, that user with that name have been existed before.

When i installed ISPconfig, it was a fresh system, without any special users or anything like this.
And having a look into this file, there are no such users.
I mean, i tried weared names there to be sure there cannot be a user called like that..it did not help..

I hope someone can help me with that to problems..

thank you
Reply With Quote
  #6  
Old 17th December 2006, 13:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Quote:
Originally Posted by maYer
Hello!

No it has absolutely nothing to do with the recycle bin..it`s empty..

So where could the problem then come from?. its not important which name i type in for the username, every name is in "use". The "maximum user" limit is set to 50, 13 are in use, no no reasons here.

What could be the problem in the part, that the user is shown at the wrong place ?

thank you a lot
Please have a look at the usernames in isp_isp_user, is there anything unusual in one of the records, e.g a empty username.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 18th December 2006, 18:01
maYer maYer is offline
Junior Member
 
Join Date: Oct 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

isp_user looks absolutely normal.

No empty usernames, no wildcards, no dublicate ids, every user has doctype 1014..
The only( if thats stange) thing is, that one user has no NULL values under spam_blacklist / spam_whitelist, its just empty.

Iam really a bit helpless, thank you for all your afford
Reply With Quote
  #8  
Old 18th December 2006, 20:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Then I guess there must be some incorrect entry in isp_dep or isp_nodes, but thats not easy to debug.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig Database Configuration asyadiqin Installation/Configuration 2 15th November 2008 02:56
Mail System doesnt work! crichton Installation/Configuration 3 18th September 2007 00:49
Ability to Select Database Name / Username SleeperZ Tips/Tricks/Mods 17 19th April 2007 12:45
ISPConfig and adding an SQL Database Texaskilt General 1 7th December 2006 10:52
Recreating ISPConfig database retran Installation/Configuration 2 16th April 2006 00:22


All times are GMT +2. The time now is 10:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.