#1  
Old 3rd December 2006, 20:15
SyRenity SyRenity is offline
Junior Member
 
Join Date: Nov 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Pure domain DNS doesn't work

Hi.

I have one site that doesn't work when accessed via pure domain (i.e. http://somesite.com) - it shows the ISPConfig Shared IP page. It does work when accessed via www servername (http://www.somesite.com).

The rest of the site work with pure domain without problems. Any idea what can be done here?

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 3rd December 2006, 20:36
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 147 Times in 128 Posts
Default

two things that could be wrong (hard to say with the info you are giving)

a) Create at pure domain an A record with as host @ and point it to your server.

or

b) In ISPconfig go to ISPmanager, and select the domain (somesite.com)
Now go to the Co-domains tab, and click on NEW. Leave the "Hostname:" empty, and enter in the "Domain:" somesite.com
When done, click on save.

Last edited by edge; 3rd December 2006 at 20:39.
Reply With Quote
  #3  
Old 4th December 2006, 11:25
SyRenity SyRenity is offline
Junior Member
 
Join Date: Nov 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi.

I was missing the @ record. I added it, hopefully it will resolve the problem.


Update: Unfortunately, it didn't work. I added the @ record, and the Co-domains tab already had the somesite.com in it.

The domain in question is www.hatarsi.com

Thanks.

Last edited by SyRenity; 4th December 2006 at 11:32.
Reply With Quote
  #4  
Old 4th December 2006, 13:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

What's in your Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th December 2006, 15:23
SyRenity SyRenity is offline
Junior Member
 
Join Date: Nov 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here it is:

######################################
# Vhost: www.hatarsi.com:80
######################################
#
#
<VirtualHost 64.187.96.17:80>
ServerName www.hatarsi.com:80
ServerAdmin webmaster@hatarsi.com
DocumentRoot /var/www/web14/web
ServerAlias hatarasi.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web14/log/error.log
Alias /error/ "/var/www/web14/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
</VirtualHost>

Thanks.
Reply With Quote
  #6  
Old 4th December 2006, 15:41
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 147 Times in 128 Posts
Default

Not sure why it's not working, but try to fix your DNS 1st!
http://www.dnsreport.com/tools/dnsre...in=hatarsi.com
Reply With Quote
  #7  
Old 5th December 2006, 17:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by SyRenity
Here it is:

######################################
# Vhost: www.hatarsi.com:80
######################################
#
#
<VirtualHost 64.187.96.17:80>
ServerName www.hatarsi.com:80
ServerAdmin webmaster@hatarsi.com
DocumentRoot /var/www/web14/web
ServerAlias hatarasi.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web14/log/error.log
Alias /error/ "/var/www/web14/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
</VirtualHost>

Thanks.
The problem is you created a Co-Domain hatarasi.com, not hatarsi.com!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Same host 'www' at (n) domain at the same ip doesn't work OdinsChrist Installation/Configuration 2 16th November 2006 19:44
DNS Not Resolving Domain Name asyadiqin Installation/Configuration 10 3rd November 2006 14:47
Unsure of DNS, hosts, and domain name plethera21 Installation/Configuration 1 4th September 2006 11:01
Cannot add domain to DNS because it exists, but it's not in the list. benbalbo Installation/Configuration 4 2nd December 2005 07:07


All times are GMT +2. The time now is 04:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.