Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th November 2006, 19:18
omadon omadon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default emails domains and co-domains question bug or a feature

Why is email aliases so strangely generated.

Example:

I create site www.dummy.net with dns records.
System creates in dns domain dummy.net with www A record.
When I add email account test@dummy.net (account user01)
in virtusertable automatically is generated test@www.dymmy.net

Normally, 99% people doesn't have email test@www.dummy.net
but test@dummy.net. To fix this problem I added in co-domain
dummy.net and now there are two entries in virtusertable for
account user01 test@www.dummy.net and test@dummy.net

My question is what do I need to change in code and where so that
aliases are generated ONLY for sites specified in co-domains I realy
don't need alias @www.dummy.net. If I want one I can always add
it in co-domain.

One more question, where in GUI can I see what version of ispconfig
is installed.

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 25th November 2006, 14:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by omadon
Why is email aliases so strangely generated.

Example:

I create site www.dummy.net with dns records.
System creates in dns domain dummy.net with www A record.
When I add email account test@dummy.net (account user01)
in virtusertable automatically is generated test@www.dymmy.net

Normally, 99% people doesn't have email test@www.dummy.net
but test@dummy.net. To fix this problem I added in co-domain
dummy.net and now there are two entries in virtusertable for
account user01 test@www.dummy.net and test@dummy.net

My question is what do I need to change in code and where so that
aliases are generated ONLY for sites specified in co-domains I realy
don't need alias @www.dummy.net. If I want one I can always add
it in co-domain.
That's the default behaviour because sometimes there are people that need test@www.example.com. If you don't need it, you can set "External Mailserver" for that specific domain (on the "Options" tab), and it will be excluded from the Postfix configuration). BTW, there is no need to create a Co-Domain www.dummy.net if you have www.dummy.net on the "Basis" tab.

Quote:
Originally Posted by omadon
One more question, where in GUI can I see what version of ispconfig
is installed.
Tools -> Software Version.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th November 2006, 09:27
omadon omadon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks

External mailserver option works fine. Can you point me in what file I can
change that default option for www.domins is external mailserver.

Thanks
Reply With Quote
  #4  
Old 27th November 2006, 10:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,787
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

You can change this default in the form editor and in the dtabase structure, but it might break your setup so I dont recommend this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.