Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th October 2005, 23:22
isopure isopure is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ERROR 403 permission and access problem

Hello

I have installed ispconfig 2.0.9 on Debian Sarge as per the great instructions provided.
When it comes to sites, I am able to create directories under the web directory, but I am unable to access these directories. i.e. www.domain.com/image/somepic.jpg or anything under these directories. I get a 403 error which states to following

The following error occurred:
You are not permitted to access the requested URL
Please contact the Webmaster with any queries.

I verified ownership of directory and access permission and all seems well but I keep getting the 403 error.
Any help will greatly be welcomed.

Thx in advance.
Reply With Quote
Sponsored Links
  #2  
Old 9th October 2005, 13:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,492
Thanks: 835
Thanked 5,533 Times in 4,351 Posts
Default

You are shure that the DNS A-Record for the Domain points already to your server. This may take up to 2-3 days.
Reply With Quote
  #3  
Old 9th October 2005, 18:14
isopure isopure is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
You are shure that the DNS A-Record for the Domain points already to your server. This may take up to 2-3 days.
The DNS A-record has resolved itself about 4 days ago. I am able to access the site i.e. www.domain.com and any file that is in the web root, but again when it comes to any directories made in the web root and access file from it... I get the error. do i have to create .htaccess for each site and set-up permissions there... under which directory

This is what my apache2.conf looks like:

<Directory /var/www/*/web>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

Thx again
Reply With Quote
  #4  
Old 9th October 2005, 18:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,492
Thanks: 835
Thanked 5,533 Times in 4,351 Posts
Default

There are no additional htaccess files nescessary.

Can you please post the output from the comand "ls -la" for the directory image and the file somepic.jpg
Reply With Quote
  #5  
Old 9th October 2005, 19:28
isopure isopure is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
There are no additional htaccess files nescessary.

Can you please post the output from the comand "ls -la" for the directory image and the file somepic.jpg
the output is as follows from "ls -la"

drwxrw-r-- 2 web3_obed web1 4096 Oct 7 17:21 images
-rw-r--r-- 1 web3_obed web1 139015 Oct 9 11:12 somepic.jpg

but the user that should own the dirctory is web1_admin... would it make a diff if I chown -R the file and directory to web1_admin:web1 when it comes to ispconfig.

again thx for the quick reply
Reply With Quote
  #6  
Old 9th October 2005, 22:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by isopure
the output is as follows from "ls -la"

drwxrw-r-- 2 web3_obed web1 4096 Oct 7 17:21 images
-rw-r--r-- 1 web3_obed web1 139015 Oct 9 11:12 somepic.jpg

but the user that should own the dirctory is web1_admin... would it make a diff if I chown -R the file and directory to web1_admin:web1 when it comes to ispconfig.

again thx for the quick reply
Directories must have execute permissions for each user/group. But the images directory only has execute permissions for the owner.
If you run
Code:
chmod 775 images
or
Code:
chmod 755 images
then it will work.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Issues - Access Forbidden! rytech Installation/Configuration 23 22nd June 2006 16:25


All times are GMT +2. The time now is 09:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.