#1  
Old 6th October 2005, 12:17
neu2linux neu2linux is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Unable to open ISPConfig Web

Hello all,

Want to say thanks very much for the great How-To's,

I am however having an issue. I am unable to open the ISPConfig in the web. I have tried several things I have read on the forums here. (and I have removed my actual domain name and replaced with mydomain just for posting purposes)

At first I read someone elses post that that had to run /etc/init.d/ispconfig_server start to get working, I did as well and it had asked me for my passphrase, enter it in, seemed to start up, but still unable to connect to the web interface.

If I use http://mydomain.net:81 or http://www.mydomain.net:81 it says:

Code:
Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.


Hint: https://mydomain.net:81/


--------------------------------------------------------------------------------

Apache/1.3.33 Server at mydomain.net Port 81
But when I use https://mydomain.net:81 or https://www.mydomain.net:81 it says:
Code:
The page cannot be displayed 
The page you are looking for is currently unavailable.
The Web site might be experiencing technical difficulties,
or you may need to adjust your browser settings.
Here is my netstat -tap
Code:
login as: root
root@192.168.0.4's password:
Last login: Thu Oct  6 04:57:48 2005
[root@server ~]# /etc/init.d/ispconfig_server start
Starting ISPConfig system...
Apache/1.3.33 mod_ssl/2.8.23 (Pass Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide us with the pass phrases.

Server mydomain.net:81 (RSA)
Enter pass phrase:

Ok: Pass Phrase Dialog successful.
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
[root@server ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:32768                 *:*                     LISTEN      -
tcp        0      0 *:nfs                   *:*                     LISTEN      -
tcp        0      0 *:imaps                 *:*                     LISTEN      6267/xinetd
tcp        0      0 *:pop3s                 *:*                     LISTEN      6267/xinetd
tcp        0      0 *:996                   *:*                     LISTEN      6328/rpc.rquotad
tcp        0      0 server.mydomain:10026 *:*                     LISTEN      8456/master
tcp        0      0 *:mysql                 *:*                     LISTEN      4914/mysqld
tcp        0      0 *:netbios-ssn           *:*                     LISTEN      6754/smbd
tcp        0      0 *:pop3                  *:*                     LISTEN      6267/xinetd
tcp        0      0 *:imap                  *:*                     LISTEN      6267/xinetd
tcp        0      0 *:sunrpc                *:*                     LISTEN      5005/portmap
tcp        0      0 *:x11                   *:*                     LISTEN      5959/X
tcp        0      0 *:81                    *:*                     LISTEN      8003/ispconfig_http
tcp        0      0 *:628                   *:*                     LISTEN      5110/rpc.statd
tcp        0      0 *:ftp                   *:*                     LISTEN      8492/proftpd: (acce
tcp        0      0 server.mydomain:5335 *:*                     LISTEN      6058/mDNSResponder
tcp        0      0 *:smtp                  *:*                     LISTEN      8456/master
tcp        0      0 *:635                   *:*                     LISTEN      6392/rpc.mountd
tcp        0      0 *:microsoft-ds          *:*                     LISTEN      6754/smbd
tcp        0      0 *:http                  *:*                     LISTEN      8327/httpd2
tcp        0      0 *:x11                   *:*                     LISTEN      5959/X
tcp        0      0 *:ssh                   *:*                     LISTEN      6188/sshd
tcp        0      0 *:smtp                  *:*                     LISTEN      8456/master
tcp        0      0 *:https                 *:*                     LISTEN      8327/httpd2
tcp        0      0 ::ffff:192.168.0.4:ssh  ::ffff:192.168.0.2:1318 ESTABLISHED 7762/1
Another thing is when I run chkconfig --add ispconfig_server or chkconfig --levels 235 ispconfig_server on it says:
Code:
login as: root
root@192.168.0.4's password:
Last login: Thu Oct  6 05:03:31 2005 from 192.168.0.2
[root@server ~]# chkconfig --add ispconfig_server
service ispconfig_server does not support chkconfig
[root@server ~]# chkconfig --levels 235 ispconfig_server on
service ispconfig_server does not support chkconfig
When I try to connect on the actual box itself using https://localhost:81 I get an error saying.
Code:
Could not establish an encrypted connection because certificate presented 
by localhost is invalid or corrupted. Error Code: -8182
Another strange thing is if I visit my normal domain using http:// on IE I get the default page saying bleh bleh, server installed ect.. With info on apache and mandriva, ect.. But...

If I visit it using FireFox, it shows the site in text, including the html tags. Not even parsing the site or something? I tried via Firefox 1.06 and 1.07 on both Windows XP and Linux.

My normal http:// domain still works however in IE

Hope someone can help me

Last edited by neu2linux; 6th October 2005 at 12:40.
Reply With Quote
Sponsored Links
  #2  
Old 6th October 2005, 13:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Don't know what's going on on your system.
Maybe it helps if you uninstall ISPConfig (run /root/ispconfig/uninstall) and then install ISPConfig again, but this time you should choose http instead of https in the installer; also have a look at http://www.ispconfig.org/manual_installation.htm. It says:

Quote:
In step 7 ("Encrypting RSA private key of CA with a pass phrase for security [ca.key]")and step 8 ("Encrypting RSA private key of SERVER with a pass phrase for security [server.key]") of the certificate creation process you are asked if you want to encrypt the respective key now. Choose n there because otherwise you will always be asked for a password whenever you want to restart the ISPConfig system which means it cannot be restarted without human interaction!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th October 2005, 14:22
neu2linux neu2linux is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I will give a reinstall a go, and choose http this time around, kinda weird tho, I had tried (before reinstalling my os) using webmin and https worked fine with it, of course that was on Xandros, so not sure if that made any difference. But Xandros atm seems a bit "slow" compared to Mandriva and Fedora Core 4.

Oh quick question, the LAN IP of my box is 192.168.0.4 so that is the IP I would put for "Please enter the IP address of the ISPConfig web: E.g. 192.168.0.1" aye? Or it need to be 192.168.0.1 (gateway of router) ?

Anyways, I am going to get to work on that, thanks much for the reply and I will post back and let you know how it went.

// Regards,
neu2linux

Last edited by neu2linux; 6th October 2005 at 14:25.
Reply With Quote
  #4  
Old 12th October 2005, 23:46
Critical Critical is offline
Junior Member
 
Join Date: Oct 2005
Posts: 18
Thanks: 0
Thanked 1 Time in 1 Post
Default

I have a similar problem, I've searched the forums for an answer to it and haven't been able to figure it out. I'm running it on a dedicated machine running FC4. The installation finished and it is running however I cannot access it through the web. My installation should be https://mydomain:81 and it doesn't work. From what I've read already it could be a host problem? So far I havent been able to figure it out.

If someone could point me in the right direction or give me an example of what the host file should be (and works) would be great. Mine looks like:
Code:
xxx.xxx.xxx.xxx     www.mydomain.com     mydomain.com
Any ideas?
Reply With Quote
  #5  
Old 13th October 2005, 00:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by Critical
I have a similar problem, I've searched the forums for an answer to it and haven't been able to figure it out. I'm running it on a dedicated machine running FC4. The installation finished and it is running however I cannot access it through the web. My installation should be https://mydomain:81 and it doesn't work. From what I've read already it could be a host problem? So far I havent been able to figure it out.

If someone could point me in the right direction or give me an example of what the host file should be (and works) would be great. Mine looks like:
Code:
xxx.xxx.xxx.xxx     www.mydomain.com     mydomain.com
Any ideas?
Can you see at least the login screen when you use the IP address instead of mydomain.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 13th October 2005, 05:19
Critical Critical is offline
Junior Member
 
Join Date: Oct 2005
Posts: 18
Thanks: 0
Thanked 1 Time in 1 Post
Default

No, I cannot. I've used the IP, https/http, domain, with and without www, and with the default port 81. I get a "Page cannot be displayed" error.
Reply With Quote
  #7  
Old 1st April 2006, 21:41
Aiken Aiken is offline
Junior Member
 
Join Date: Apr 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by neu2linux
Another strange thing is if I visit my normal domain using http:// on IE I get the default page saying bleh bleh, server installed ect.. With info on apache and mandriva, ect.. But...

If I visit it using FireFox, it shows the site in text, including the html tags. Not even parsing the site or something? I tried via Firefox 1.06 and 1.07 on both Windows XP and Linux.

My normal http:// domain still works however in IE

Hope someone can help me
On this point I can. I had exactly the same thing after setting up my apache server. If you view the http headers in firefox you'll find the content being server as plain text (mime type text/plain). Firefox is actually rendering the page correctly for this mime type, it's IE that has it wrong.

Now down to what caused the content to be served up as plain text. When configuring the server I'd commented out all modules that I thought I didn't need. Turns out I got one I shouldn't have - mod_mime and the directives that went with it. I put these back, restarted apache in and it was fine.

I can't get the the http config file from home, but I'll check on Monday and post an update with the directives you need to resolve this.

EDIT:
As promised here are the lines that need to be in the config file to resolve the problem with firefox displaying the page as source

LoadModule mime_module modules/mod_mime.so

# TypesConfig describes where the mime.types file (or equivalent) is
# to be found.
#
TypesConfig conf/mime.types

# DefaultType is the default MIME type the server will use for a document
# if it cannot otherwise determine one, such as from filename extensions.
# If your server contains mostly text or HTML documents, "text/plain" is
# a good value. If most of your content is binary, such as applications
# or images, you may want to use "application/octet-stream" instead to
# keep browsers from trying to display binary files as though they are
# text.
#
DefaultType text/plain

Last edited by Aiken; 3rd April 2006 at 21:50.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HowTo start developing ISPConfig till Developers' Forum 18 25th April 2014 21:43
Fail to open ISPConfig site: firefox 8182 BigB Installation/Configuration 100 31st March 2010 17:19
Mail System doesnt work! crichton Installation/Configuration 3 18th September 2007 00:49
Changing values on ISPConfig installation Luciano Installation/Configuration 4 17th August 2005 00:32
Problem opening firewall port weedguy General 15 12th August 2005 02:05


All times are GMT +2. The time now is 08:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.