#1  
Old 19th October 2006, 06:02
pjaric pjaric is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default calling on spamc?

I've been trying to get the mail to go throught spamc/spamd rather than spamassassin, but no luck.

I've selected enable Spamd in /etc/default/spamassassin and changed the .spamassassin.rc where it use to say:
:0fw
* < 256000
| /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

now it is

:0fw
* < 256000
| /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamc

The mails do not get scanned. What other file can I look at to change this?
Reply With Quote
Sponsored Links
  #2  
Old 19th October 2006, 09:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

1) /etc/default/spamassassin is not the config file for the ISPConfig spamassassin. The config file is in/home/admispconfig/ispconfig/tools/spamassassin/etc/

2) The ISPConfig spamd is not started and there is no start script for it, because ISPConfig does not use it.

3) The main problem with spamc is and thats why it is not enabled in ISPConfig is that spamd is not able to read the spamassassin preferences file that ISPConfig uses because spamc does not ahve a parameter to provide the location of the user_prefs file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
cnavarro (17th December 2007)
  #3  
Old 20th October 2006, 02:51
pjaric pjaric is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the answer. Make sense to me now even thought I was beating my head against the wall trying to make it work.

Is it possible to activate spamd and have it read another file, something that IspConfig does not create?
Reply With Quote
  #4  
Old 20th October 2006, 10:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

What you might try is this:

1) Install spamc / spamd from your linux distribution and make shure it is automatically started at boot time.

2) insert the path to the spamc program from your linux distribution in the file .spamassassin.rc instead of the ISPConfig spamc path.

This will enable spamd with your global spamassassin settings.

To use the settings from ISPConfig, you can try to create a symlink inside of the subdirectory .spamassassin that can be found in each users home directory like this:

Quote:
ln -s ../.user_prefs .user_prefs
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th October 2006, 16:47
pjaric pjaric is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I installed spamd and it works well now after the modifications.

The problem I am having is that it is not reading any user_prefs file, nor any local.cf file.

The mail is being scanned with 5.0 as required hits no matter what changes I make in any of the user_pref files. It seems that the default is 5 but I do not know where it is reading it from.

Also, if I stay with ISPconfig's spamassassin rather than spamce, where do I install RulesDuJour? /etc/mail/spamassassin? or under /home/admispconfig/......./spamassassin?
Reply With Quote
  #6  
Old 21st October 2006, 12:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

If you use the ISPConfig spamassassin, you must do all modifications and installations in /home/admispconfig/......./spamassassin
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 7th August 2007, 02:20
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by pjaric
The problem I am having is that it is not reading any user_prefs file, nor any local.cf file.
I see the post is quite old, but it helped me a lot today.
As a remark: the actual user_prefs file is called user_prefs and not .user_prefs (no dot)

So the command is
Code:
ln -s ../.user_prefs user_prefs
(works only for users which are not domain administrators anyway)
for them you have to point the link somewhere else
Code:
ln -s ../user/<username>/.user_prefs user_prefs
Currently I have not yet hacked the ispconfig scripts to do that. I leave that as an exercise ;-)
Reply With Quote
The Following User Says Thank You to jmroth For This Useful Post:
till (7th August 2007)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calling $Response->Write from perl savimonty Programming/Scripts 5 7th April 2006 16:03


All times are GMT +2. The time now is 08:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.