#1  
Old 3rd October 2005, 18:57
cartdev cartdev is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL connection problem

I had problems with MySQL I think because I used some unusual carachters in my root password. Now I've changed the pass both in MySQL and in the /home/admispconfig/ispconfig/lib/config.inc.php. I can login to the MySQL monitor within the ispconfigdb at the command line, but when I attempt to access the web page, I get the login screen but it says "ERROR 101: wrong username or password." when I use admin and admin. It appears that ispconfig is not even hitting the database or if it is, that the admin:admin record is missing.

Also, it is a pain to go through the install so many times. Can you save it at anypoint to start over? Just not having to type the cert stuff would be helpful.
Reply With Quote
Sponsored Links
  #2  
Old 3rd October 2005, 19:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

I guess that at least the admin user record is missing, if not the whole ISPConfig database. Do you have a phpMyAdmin where you can check that?

Quote:
Also, it is a pain to go through the install so many times. Can you save it at anypoint to start over? Just not having to type the cert stuff would be helpful.
No, you have to run the whole installation again. Delete the directories /home/admispconfig and /root/ispconfig before and also the ISPConfig database if there is one...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd October 2005, 19:40
cartdev cartdev is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the help. Know that I have succeeded in getting this up on another box, but it took some fiddling. Now I'm trying to make an exact recipe for putting this on several boxes.

On a whim, I reinstalled things again, despite the fact that the last install completed. This time, I got this error:

HTML Code:
Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!FreshClam is already running!
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
I get the exact same login problem on the website, i.e. "ERROR 101: wrong username or password."

Oh, I just checked the ispconfig database and it doesn't have any tables. WHat can I do to build this db properly?

Bob

Last edited by cartdev; 3rd October 2005 at 19:48.
Reply With Quote
  #4  
Old 3rd October 2005, 19:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by cartdev
Oh, I just checked the ispconfig database and it doesn't have any tables. WHat can I do to build this db properly?
Delete the current ISPConfig installation and install again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd October 2005, 19:59
cartdev cartdev is offline
Junior Member
 
Join Date: Sep 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just did delete the install and both directores /root/isp... and /home/admin...
and the above is what I reported. A db was created, but without tables. Reinstalling yet again, won't change anything. How can I create the tables?

mysql> select * from isp_server;
ERROR 1146 (42S02): Table 'ispconfigdb.isp_server' doesn't exist
Reply With Quote
  #6  
Old 3rd October 2005, 20:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by cartdev
I just did delete the install and both directores /root/isp... and /home/admin...
and the above is what I reported. A db was created, but without tables. Reinstalling yet again, won't change anything. How can I create the tables?

mysql> select * from isp_server;
ERROR 1146 (42S02): Table 'ispconfigdb.isp_server' doesn't exist
You can only create them using the installer because some entries are created on-the-fly.
Before you install ISPConfig please delete the whole ispconfig database, not only the tables in it!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
Mysql Problem Adding adamluz General 2 20th September 2005 09:33
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41
Mysql ejs Installation/Configuration 5 12th August 2005 07:01
MySQL Privileges mcfly Server Operation 4 26th May 2005 19:00


All times are GMT +2. The time now is 18:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.