Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th May 2005, 15:37
ExCIA ExCIA is offline
Junior Member
 
Join Date: May 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Setup - Debian Woody (3.0)... sending mail from my XP box?

BTW... this is one of the best HOWTOs website I've ever come across. Two thumbs up.

Anyway, I have completed the 'The Perfect Setup - Debian Woody' and what do I need to do in order to send mails from my XP machines (outlook) to my Debian server and let the Debian server deliver the mail to my ISP?

I have three XP machines in the network and the forth one is the Debian server (192.168.0.3). All is connected through a router (broadband).

My ISP's (NTLWorld) smtp/pop3 servers are:

smtp.ntlworld.com
pop.ntlworld.com

To send mail I have to use SMTP authentication.

For example, if my email address is john.doe@ntlworld.com does that means I have to create an account on the Debian server as john.doe?

Last edited by ExCIA; 7th May 2005 at 15:40.
Reply With Quote
Sponsored Links
  #2  
Old 8th May 2005, 14:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
For example, if my email address is john.doe@ntlworld.com does that means I have to create an account on the Debian server as john.doe?
No, the user name doesn't matter, you could create a user named sampleuser with the password samplepassword.

Now you have to prepare Postfix for relaying through another server:

Code:
postconf -e 'smtp_sasl_auth_enable = yes'
postconf -e 'smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd'
postconf -e 'smtp_sasl_security_options ='


chown root:root /etc/postfix/sasl_passwd
chmod 600 /etc/postfix/sasl_passwd
postmap /etc/postfix/sasl_passwd
/etc/init.d/postfix restart
In /etc/postfix/sasl_passwd you put your ISP's SMTP server and a user name and password that are allowed to send through that server:

Code:
smtp.ntlworld.com   Username on smtp.ntlworld.com:Password
Whenever you change /etc/postfix/sasl_passwd you have to do the following:
Code:
postmap /etc/postfix/sasl_passwd
/etc/init.d/postfix restart
Now if you want to send email from your XP machine you tell your email client to use the user sampleuser with the password samplepassword along with your internal SMTP server (192.168.0.3).
And fetching emails doesn't change: you simply fetch them from your ISP's POP3 server (pop.ntlworld.com).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th May 2005, 20:12
ExCIA ExCIA is offline
Junior Member
 
Join Date: May 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What is the difference between doing what you suggest and simply add an ISP's smtp server address in the 'relayhost =' in the /etc/postfix/main.cf file?


Good thing you mentioned /etc/postfix/sasl_passwd because mine doesn't exist, which I find that pretty strange?

Last edited by ExCIA; 8th May 2005 at 21:16.
Reply With Quote
  #4  
Old 9th May 2005, 12:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
What is the difference between doing what you suggest and simply add an ISP's smtp server address in the 'relayhost =' in the /etc/postfix/main.cf file?
Right, I forgot that one... You have to set the relayhost variable in /etc/postfix/main.cf:

Code:
postconf -e 'relayhost = smtp.ntlworld.com'
And don't forget to restart Postfix afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd September 2006, 16:22
3cwired_com 3cwired_com is offline
Senior Member
 
Join Date: Sep 2006
Posts: 100
Thanks: 3
Thanked 3 Times in 2 Posts
Default

What if I don't have a password for my isp smtp, what if I just use the address?
__________________
Behind every great fortune lies a crime.
www.3cwired.com - Web Design/SEO/Repair/Sales/Upgrades
www.galants.org - The Home for Galant Enthusiasts
www.locatemyip.com - More than just free IP displays
Reply With Quote
The Following User Says Thank You to 3cwired_com For This Useful Post:
robertoshulze2257 (15th May 2014)
  #6  
Old 3rd September 2006, 18:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

If you dont have a password, just add the relayhosts line in main.cf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 5th October 2006, 19:21
fredsuperstar fredsuperstar is offline
Junior Member
 
Join Date: Oct 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great! I've been looking everywhere for this workaround!

I did every step, and I added relay = [smtph.sympatio.ca] to my .conf. However, postfix is still unable to send mail because of a 550 error. Here is my log:

Oct 5 13:18:08 localhost postfix/smtp[28537]: setting up TLS connection to smtp.bc.hotmail.com
Oct 5 13:18:08 localhost postfix/smtp[28537]: certificate peer name verification failed for smtp.bc.hotmail.com: CommonName mis-match: smtphm.sympatico.ca
Oct 5 13:18:08 localhost postfix/smtp[28537]: Verified: subject_CN=smtphm.sympatico.ca, issuer=Entrust.net Secure Server Certification Authority
Oct 5 13:18:08 localhost postfix/smtp[28537]: TLS connection established to smtp.bc.hotmail.com: TLSv1 with cipher RC4-MD5 (128/128 bits)
Oct 5 13:18:08 localhost postfix/smtp[28537]: 71CCB13413B: to=<fred@XXXXXX.ca>, relay=smtp.bc.hotmail.com[65.54.191.190], delay=1, status=bounced (host smtp.bc.hotmail.com[65.54.191.190] said: 550 5.7.3 Requested action aborted; user not authenticated (in reply to MAIL FROM command)

Seems like the auth don't work..
Any i-d what I could do next?

--

Last edited by fredsuperstar; 5th October 2006 at 19:24.
Reply With Quote
  #8  
Old 6th October 2006, 15:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

You need to authenticate at the other mail server. Did you follow these instructions? http://www.howtoforge.com/forums/sho...07&postcount=2
http://www.howtoforge.com/forums/sho...09&postcount=4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.