Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th September 2006, 00:15
wvsailor wvsailor is offline
Junior Member
 
Join Date: Sep 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Question FATAL ERROR: register_globals is disabled in php.ini, please enable it

Installed ispConfig on FC5, good install! Excellent instructions and tutorials!

Now I'm trying to install osCommerce, and I received the following error:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

I checked the site settings, php is enabled in the site, and I even checked php.ini and register globals is ON.

Any help would be greatly appreciated!
Jim
Reply With Quote
Sponsored Links
  #2  
Old 19th September 2006, 10:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,186
Thanks: 829
Thanked 5,417 Times in 4,259 Posts
Default

In which php.ini file did you enable register_globals? There are 3 files. Did you restart your apache webserver?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th September 2006, 10:29
wvsailor wvsailor is offline
Junior Member
 
Join Date: Sep 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Question php.ini

I'm not sure which php.ini I should edit (or where they are). Is it possible to only make the changes specifically for each site that is hosted or would it effect ALL sites? There are several changes I have to make for osCommerce (at least the install) to work properly.
Thanks in advance!
Best regards!
Jim
Reply With Quote
  #4  
Old 20th September 2006, 16:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Have a look here: http://www.howtoforge.com/forums/sho...gister_globals
http://www.howtoforge.com/forums/sho...gister_globals
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th September 2006, 19:45
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

you could create a .htaccess and enable register_globals just for that site:

Code:
php_admin_value safe_mode Off
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! micko_escalade Installation/Configuration 35 30th March 2007 11:31
colocation problem d3m0nic Installation/Configuration 14 23rd June 2006 23:18
Install Error Alpha Installation/Configuration 9 6th April 2006 19:48
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42


All times are GMT +2. The time now is 14:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.