Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th September 2006, 07:56
ozonblue ozonblue is offline
Junior Member
 
Join Date: Aug 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default .htaccess login challenge broken with mod_rewrite

Hi all.

I'm running ISPconfig on Debian Sarge with perfect setup.

I'm using the WebGUI content management system on some virtual hosts which rewrites some URL's - *excluding* the /stats/ directory which is protected by ISPconfig's .htaccess file.

When I remove that .htaccess file everything works fine - which tells me that mod_rewrite is working correctly. When the .htaccess file is present - I get an unauthorised access message - but the login challenge dialog box doesn't pop up as it does on the virtual hosts without the rewrite rules.

I try to delete the .htaccess file in the /stats/ directory - the problem is that ISPconfig keep on automatically adding that .htaccess file.

I'm sure it is a issue with mod_rewrite not working well with .htaccess - perhaps somebody has a bit of advice ?

Here is the rewrite rules from my "optional" Apache directives setting.

**********************************************
<Files ~ '.(pl)$'>
SetHandler perl-script
PerlHandler ModPerl::Registry
</Files>
RewriteEngine On
RewriteRule ^/extras/ - [L]
RewriteRule ^/env.pl - [L]
RewriteRule ^/uploads/ - [L]
RewriteRule ^/stats/ - [L]
RewriteRule ^/images/ - [L]
RewriteRule ^/images_files/ - [L]
RewriteRule ^/extras/ - [L]
RewriteRule ^/(.*) /index.pl/$1
*****************************************
Reply With Quote
Sponsored Links
  #2  
Old 13th September 2006, 08:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

I guess that not all directives are allowed for a .htaccess file on your server. Please try this:

http://www.howtoforge.com/forums/sho...33&postcount=3
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th September 2006, 10:09
ozonblue ozonblue is offline
Junior Member
 
Join Date: Aug 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
I guess that not all directives are allowed for a .htaccess file on your server. Please try this:

http://www.howtoforge.com/forums/sho...33&postcount=3
AllowOverride All didn solve the problem.

i have however noticed that the error message is produced by the browser - not the server. Adding another rewrite rule that excluded rewriting browser requests for /error/ mysteriously soved the problem :-)

regards,

Eugene Coetzee
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 12:13
Postfix login broken mantasman Server Operation 2 9th May 2006 00:10
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 18:11
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 06:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.