#1  
Old 3rd September 2006, 12:26
chrno chrno is offline
Member
 
Join Date: Apr 2006
Posts: 70
Thanks: 0
Thanked 1 Time in 1 Post
Default install Net::DNS

Hi,

Just preparing another server for ISPConfig (using The Perfect Setup - Debian Sarge (3.1) - Page 5) and I came across an error which has not happen before ...


On "install Net:NS" -> I get the following error ???
Code:
Net-DNS-0.58/contrib/loc2earth.fcgi
Net-DNS-0.58/contrib/loclist.pl
Net-DNS-0.58/contrib/README
Net-DNS-0.58/demo/
Net-DNS-0.58/demo/axfr
Net-DNS-0.58/demo/check_soa
Net-DNS-0.58/demo/check_zone
Net-DNS-0.58/demo/example_recurse.pl
Net-DNS-0.58/demo/mresolv
Net-DNS-0.58/demo/mx
Net-DNS-0.58/demo/perldig
Net-DNS-0.58/demo/README
Net-DNS-0.58/demo/trace_dns.pl
Net-DNS-0.58/DNS.xs
Net-DNS-0.58/lib/
Net-DNS-0.58/lib/Net/
Net-DNS-0.58/lib/Net/DNS/
Net-DNS-0.58/lib/Net/DNS/FAQ.pod
Net-DNS-0.58/lib/Net/DNS/Header.pm
Net-DNS-0.58/lib/Net/DNS/Nameserver.pm
Net-DNS-0.58/lib/Net/DNS/Packet.pm
Net-DNS-0.58/lib/Net/DNS/Question.pm
Net-DNS-0.58/lib/Net/DNS/Resolver/
Net-DNS-0.58/lib/Net/DNS/Resolver/Base.pm
Net-DNS-0.58/lib/Net/DNS/Resolver/Cygwin.pm
Net-DNS-0.58/lib/Net/DNS/Resolver/Recurse.pm
Net-DNS-0.58/lib/Net/DNS/Resolver/UNIX.pm
Net-DNS-0.58/lib/Net/DNS/Resolver/Win32.pm
Net-DNS-0.58/lib/Net/DNS/Resolver.pm
Net-DNS-0.58/lib/Net/DNS/RR/
Net-DNS-0.58/lib/Net/DNS/RR/A.pm
Net-DNS-0.58/lib/Net/DNS/RR/AAAA.pm
Net-DNS-0.58/lib/Net/DNS/RR/AFSDB.pm
Net-DNS-0.58/lib/Net/DNS/RR/CERT.pm
Net-DNS-0.58/lib/Net/DNS/RR/CNAME.pm
Net-DNS-0.58/lib/Net/DNS/RR/DNAME.pm
Net-DNS-0.58/lib/Net/DNS/RR/EID.pm
Net-DNS-0.58/lib/Net/DNS/RR/HINFO.pm
Net-DNS-0.58/lib/Net/DNS/RR/ISDN.pm
Net-DNS-0.58/lib/Net/DNS/RR/LOC.pm
Net-DNS-0.58/lib/Net/DNS/RR/MB.pm
Net-DNS-0.58/lib/Net/DNS/RR/MG.pm
Net-DNS-0.58/lib/Net/DNS/RR/MINFO.pm
Net-DNS-0.58/lib/Net/DNS/RR/MR.pm
Net-DNS-0.58/lib/Net/DNS/RR/MX.pm
Net-DNS-0.58/lib/Net/DNS/RR/NAPTR.pm
Net-DNS-0.58/lib/Net/DNS/RR/NIMLOC.pm
Net-DNS-0.58/lib/Net/DNS/RR/NS.pm
Net-DNS-0.58/lib/Net/DNS/RR/NSAP.pm
Net-DNS-0.58/lib/Net/DNS/RR/NULL.pm
Net-DNS-0.58/lib/Net/DNS/RR/OPT.pm
Net-DNS-0.58/lib/Net/DNS/RR/PTR.pm
Net-DNS-0.58/lib/Net/DNS/RR/PX.pm
Net-DNS-0.58/lib/Net/DNS/RR/RP.pm
Net-DNS-0.58/lib/Net/DNS/RR/RT.pm
Net-DNS-0.58/lib/Net/DNS/RR/SOA.pm
Net-DNS-0.58/lib/Net/DNS/RR/SPF.pm
Net-DNS-0.58/lib/Net/DNS/RR/SRV.pm
Net-DNS-0.58/lib/Net/DNS/RR/SSHFP.pm
Net-DNS-0.58/lib/Net/DNS/RR/TKEY.pm
Net-DNS-0.58/lib/Net/DNS/RR/TSIG.pm
Net-DNS-0.58/lib/Net/DNS/RR/TXT.pm
Net-DNS-0.58/lib/Net/DNS/RR/Unknown.pm
Net-DNS-0.58/lib/Net/DNS/RR/X25.pm
Net-DNS-0.58/lib/Net/DNS/RR.pm
Net-DNS-0.58/lib/Net/DNS/Update.pm
Net-DNS-0.58/lib/Net/DNS.pm
Net-DNS-0.58/Makefile.PL
Net-DNS-0.58/MANIFEST
Net-DNS-0.58/META.yml
Net-DNS-0.58/netdns.c
Net-DNS-0.58/netdns.h
Net-DNS-0.58/README
Net-DNS-0.58/t/
Net-DNS-0.58/t/.resolv.conf
Net-DNS-0.58/t/00-load.t
Net-DNS-0.58/t/00-pod.t
Net-DNS-0.58/t/00-version.t
Net-DNS-0.58/t/01-resolver-env.t
Net-DNS-0.58/t/01-resolver-file.t
Net-DNS-0.58/t/01-resolver-opt.t
Net-DNS-0.58/t/01-resolver.t
Net-DNS-0.58/t/02-header.t
Net-DNS-0.58/t/03-question.t
Net-DNS-0.58/t/04-packet-unique-push.t
Net-DNS-0.58/t/04-packet.t
Net-DNS-0.58/t/05-rr-opt.t
Net-DNS-0.58/t/05-rr-rrsort.t
Net-DNS-0.58/t/05-rr-sshfp.t
Net-DNS-0.58/t/05-rr-txt.t
Net-DNS-0.58/t/05-rr-unknown.t
Net-DNS-0.58/t/05-rr.t
Net-DNS-0.58/t/06-update.t
Net-DNS-0.58/t/07-misc.t
Net-DNS-0.58/t/08-online.t
Net-DNS-0.58/t/09-tkey.t
Net-DNS-0.58/t/10-recurse.t
Net-DNS-0.58/t/11-escapedchars.t
Net-DNS-0.58/t/11-inet6.t
Net-DNS-0.58/t/custom.txt
Net-DNS-0.58/TODO
Removing previously used /root/.cpan/build/Net-DNS-0.58

  CPAN.pm: Going to build O/OL/OLAF/Net-DNS-0.58.tar.gz



The libraries needed to support IPv6 transport have not been found.
You will need recent versions of the IO::Socket::INET6 and Socket6
libraries (from CPAN).

Testing if you have a C compiler and the needed header files....
You have a working compiler.

You appear to be directly connected to the Internet.  I have some tests
that try to query live nameservers.

Do you want to enable these tests? [y] n
Checking if your kit is complete...
Looks good
Warning: prerequisite Digest::HMAC_MD5 1 not found.
Warning: prerequisite Net::IP 1.2 not found.
Writing Makefile for Net::DNS
---- Unsatisfied dependencies detected during [O/OL/OLAF/Net-DNS-0.58.tar.gz] -----
    Digest::HMAC_MD5
    Net::IP
Shall I follow them and prepend them to the queue
of modules we are processing right now? [yes] yes
Running make test
  Delayed until after prerequisites
Running make install
  Delayed until after prerequisites
Running install for module Digest::HMAC_MD5
Running make for G/GA/GAAS/Digest-HMAC-1.01.tar.gz
Checksum for /root/.cpan/sources/authors/id/G/GA/GAAS/Digest-HMAC-1.01.tar.gz ok
Digest-HMAC-1.01/
Digest-HMAC-1.01/rfc2104.txt
Digest-HMAC-1.01/Makefile.PL
Digest-HMAC-1.01/lib/
Digest-HMAC-1.01/lib/Digest/
Digest-HMAC-1.01/lib/Digest/HMAC.pm
Digest-HMAC-1.01/lib/Digest/HMAC_SHA1.pm
Digest-HMAC-1.01/lib/Digest/HMAC_MD5.pm
Digest-HMAC-1.01/Changes
Digest-HMAC-1.01/t/
Digest-HMAC-1.01/t/rfc2202.t
Digest-HMAC-1.01/README
Digest-HMAC-1.01/MANIFEST
Removing previously used /root/.cpan/build/Digest-HMAC-1.01

  CPAN.pm: Going to build G/GA/GAAS/Digest-HMAC-1.01.tar.gz

Checking if your kit is complete...
Looks good
Warning: prerequisite Digest::SHA1 1 not found.
Writing Makefile for Digest::HMAC
---- Unsatisfied dependencies detected during [G/GA/GAAS/Digest-HMAC-1.01.tar.gz] -----
    Digest::SHA1
Shall I follow them and prepend them to the queue
of modules we are processing right now? [yes] yes
Running make test
  Delayed until after prerequisites
Running make install
  Delayed until after prerequisites
Running install for module Digest::SHA1
Running make for G/GA/GAAS/Digest-SHA1-2.11.tar.gz
Checksum for /root/.cpan/sources/authors/id/G/GA/GAAS/Digest-SHA1-2.11.tar.gz ok
Digest-SHA1-2.11/
Digest-SHA1-2.11/README
Digest-SHA1-2.11/t/
Digest-SHA1-2.11/t/bits.t
Digest-SHA1-2.11/t/badfile.t
Digest-SHA1-2.11/t/sha1.t
Digest-SHA1-2.11/MANIFEST
Digest-SHA1-2.11/fip180-1.html
Digest-SHA1-2.11/SHA1.pm
Digest-SHA1-2.11/typemap
Digest-SHA1-2.11/fip180-1.gif
Digest-SHA1-2.11/Changes
Digest-SHA1-2.11/Makefile.PL
Digest-SHA1-2.11/SHA1.xs
Removing previously used /root/.cpan/build/Digest-SHA1-2.11

  CPAN.pm: Going to build G/GA/GAAS/Digest-SHA1-2.11.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Digest::SHA1
    -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
Running make for G/GA/GAAS/Digest-HMAC-1.01.tar.gz
  Is already unwrapped into directory /root/.cpan/build/Digest-HMAC-1.01

  CPAN.pm: Going to build G/GA/GAAS/Digest-HMAC-1.01.tar.gz

    -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
Running install for module Net::IP
Running make for M/MA/MANU/Net-IP-1.25.tar.gz
Checksum for /root/.cpan/sources/authors/id/M/MA/MANU/Net-IP-1.25.tar.gz ok
Net-IP-1.25/
Net-IP-1.25/iptab
Net-IP-1.25/META.yml
Net-IP-1.25/IP.pm
Net-IP-1.25/COPYING
Net-IP-1.25/Changes
Net-IP-1.25/t/
Net-IP-1.25/t/ExtUtils/
Net-IP-1.25/t/ExtUtils/TBone.pm
Net-IP-1.25/t/ipv4.t
Net-IP-1.25/t/ipv6.t
Net-IP-1.25/ipcount
Net-IP-1.25/MANIFEST
Net-IP-1.25/Net-IP.spec.PL
Net-IP-1.25/README
Net-IP-1.25/Makefile.PL
Removing previously used /root/.cpan/build/Net-IP-1.25

  CPAN.pm: Going to build M/MA/MANU/Net-IP-1.25.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Net::IP
    -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
Running make for O/OL/OLAF/Net-DNS-0.58.tar.gz
  Is already unwrapped into directory /root/.cpan/build/Net-DNS-0.58

  CPAN.pm: Going to build O/OL/OLAF/Net-DNS-0.58.tar.gz

    -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible

cpan>
I sticked to the Perfect Setup and it's really strange because in previous install I've never seen this error before ...

Any help/assistance will be much appreciated!

chrno
Reply With Quote
Sponsored Links
  #2  
Old 3rd September 2006, 13:18
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 264
Thanked 151 Times in 131 Posts
Default

Maybe its this (the No part)?
Code:
install Net::DNS (when prompted to enable tests, choose no)
** edit **

I see you selected No..

Did you do a copy paste with the Net:: DNS install?
If so, sometimes you copy the space after the command. For me this sometimes results as sending a return.
When the question is set to default Y, than this will cause the wrong input..

Last edited by edge; 3rd September 2006 at 13:24.
Reply With Quote
  #3  
Old 3rd September 2006, 13:48
chrno chrno is offline
Member
 
Join Date: Apr 2006
Posts: 70
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks for your quick reply!

I did a copy and paste making sure that it doesn't have a space at the end. Also tried typing it in manually. Both failed with the same error ...
Reply With Quote
  #4  
Old 3rd September 2006, 18:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,704
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

I had the same problem some days ago, I guess its a bug in the cpan libraries, thei do not compile anymore under debian. Please run this command to install the same perl packages with apt:

apt-get install libhtml-parser-perl libdb-file-lock-perl libnet-dns-perl
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th September 2006, 17:01
chrno chrno is offline
Member
 
Join Date: Apr 2006
Posts: 70
Thanks: 0
Thanked 1 Time in 1 Post
Default

cool thanks Till!
Reply With Quote
The Following User Says Thank You to chrno For This Useful Post:
AbannyvabVask (6th December 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New ISPConfig Install nubtool Installation/Configuration 15 18th May 2008 16:46
problem install perl modules Cirox Installation/Configuration 10 16th May 2007 16:04
Net::DNS error d3m0nic HOWTO-Related Questions 2 24th February 2006 14:25
suse 9.3 install: E: Couldn't find package ncftp aallen Installation/Configuration 4 26th January 2006 20:02
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 04:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.