Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th August 2006, 13:55
drake drake is offline
Junior Member
 
Join Date: Aug 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL connection errors

Hi
I'm running ISPConfig on SuSE 10, and although installation went well and the system seems to be working, I get regular mysql connection errors when using ispconfig itself and with the sites that I am hosting.

The errors are generally like:
"Error (ERROR_STORAGE_FAILURE) :
in modules/core/classes/GalleryStorage.class at line 229 (MySqlStorage::error)
in modules/core/classes/GalleryStorage.class at line 449 (MySqlStorage::_getConnection)
in modules/core/classes/Gallery.class at line 223 (MySqlStorage::search)
in modules/core/classes/GallerySession.class at line 911 (Gallery::search)
in modules/core/classes/GallerySession.class at line 261 (GallerySession::_loadSessionData)
in modules/core/classes/Gallery.class at line 315 (GallerySession::init)
in init.inc at line 125 (Gallery::initSession)
in main.php at line 73"

and I get similar types of errors while using the ispconfig control panel.

Generally the errors go after refreshing the page a few times, but it makes me think that there's something wrong with the setup.

My googling etc has turned up no clues as to how I can troubleshoot this.

Any ideas would be appreciated.

Cheers

drake
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2006, 14:57
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

What kind of gallery is that or another question what happens if you run
mysql on the console and use the same username and password for that as you use on that gallery?

Actually I don't know what that gallery directly has in common with ISPConfig.
Reply With Quote
  #3  
Old 16th August 2006, 15:06
drake drake is offline
Junior Member
 
Join Date: Aug 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL storage errors

The gallery is Gallery2

The errors are not specific to the gallery (that was the first example I has to hand) - they occur with the ISPConfig admin pages, and my wordpress blogs. All the errors are similar.

Running in the console is fine - no probs. It doesn't seem to be an access problem as such, because refreshing the page a few times allows the content to be displayed properly.

Last edited by drake; 16th August 2006 at 15:11.
Reply With Quote
  #4  
Old 16th August 2006, 15:31
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Hm that sounds strange... but what is the errormessage from mysqld then?
Reply With Quote
  #5  
Old 16th August 2006, 15:57
drake drake is offline
Junior Member
 
Join Date: Aug 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL connection errors

There doesn't appear to be any error in /var/lib/mysql/mysqld.log or mysqld.log.1
Reply With Quote
  #6  
Old 17th August 2006, 16:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

This link: http://gallery.menalto.com/node/23630 means that one of your partitions could be full. What's the output of
Code:
df -h
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix - MySQL connection problem epo Installation/Configuration 7 4th August 2006 20:49
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 12:13
Email seemingly not working... Duplex Installation/Configuration 11 19th April 2006 14:48
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 10:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.