Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th August 2006, 17:20
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default all services seem to be offline in the services dialog!

Hi,

In ISPconfig, all services seem to be offline if I look to the services tab. But it isn't like this, all services are running! So I searched the Forum, and found that ispconfig has to listen to 127.0.0.1, but this seems to do not help me. Can I change this in ispconfig to listen to an other address than this, because I have a server with 3 interfaces! Please help!

with best regards
Hkaiser
Reply With Quote
Sponsored Links
  #2  
Old 15th August 2006, 16:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th August 2006, 23:49
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi here, is my netstat, please help!

Aktive Internetverbindungen (Server und stehende Verbindungen)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:32769 *:* LISTEN 1921/rpc.statd
tcp 0 0 host1.#####:8005 *:* LISTEN 3154/java
tcp 0 0 *:8009 *:* LISTEN 3154/java
tcp 0 0 *:mysql *:* LISTEN 2386/mysqld
tcp 0 0 host1.######:783 *:* LISTEN 2506/spamd -d -c -m
tcp 0 0 *:sunrpc *:* LISTEN 1903/portmap
tcp 0 0 *:webcache *:* LISTEN 3154/java
tcp 0 0 *:81 *:* LISTEN 3473/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 2507/proftpd: (acce
tcp 0 0 #####:domain *:* LISTEN 3699/named
tcp 0 0 ####:domain *:* LISTEN 3699/named
tcp 0 0 #####:domain *:* LISTEN 3699/named
tcp 0 0 #####:5335 *:* LISTEN 2225/mDNSResponder
tcp 0 0 *:smtp *:* LISTEN 2497/master
tcp 0 0 ######:rndc *:* LISTEN 3699/named
tcp 0 0 ####.deploy:http VERBUNDEN 2144/firefox-bin
tcp 0 0 ######.:52998 209.50.189.199:http VERBUNDEN 2144/firefox-bin
tcp 0 0 ######.:60094 a193-80-200-134.deploy:http VERBUNDEN 2144/firefox-bin
tcp 0 0#######.:45144 192.217.199.105:http VERBUNDEN 2144/firefox-bin
tcp 0 0 #####.:52165 ######.deploy:http VERBUNDEN 2144/firefox-bin
tcp 0 0 ######.:45170 #####:domain TIME_WAIT -
tcp 0 0 ######.:45171 #####:domain TIME_WAIT -
tcp 0 0 #####.:54450 64.233.183.104:http VERBUNDEN 2144/firefox-bin
tcp 0 0 *:imaps *:* LISTEN 2464/dovecot
tcp 0 0 *op3s *:* LISTEN 2464/dovecot
tcp 0 0 *op3 *:* LISTEN 2464/dovecot
tcp 0 0 *:imap *:* LISTEN 2464/dovecot
tcp 0 0 *:http *:* LISTEN 3655/httpd
tcp 0 0 *:ssh *:* LISTEN 2242/sshd
tcp 0 0 ::1:rndc *:* LISTEN 3699/named
tcp 0 0 *:https *:* LISTEN 3655/httpd
Reply With Quote
  #4  
Old 21st August 2006, 17:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

And what's in /etc/hosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 28th August 2006, 22:02
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

Thanks falko, you pointed me to the right direction.
Add "127.0.0.1 localhost.localdomain localhost" to the hosts file and now it works!

Thanks a lot

hkaiser
Reply With Quote
  #6  
Old 5th June 2007, 14:16
xkworld xkworld is offline
Junior Member
 
Join Date: Oct 2006
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default all services show offline but mysqld - and they're all on

Ok, all my services are showing offline but mysql. All my services are running, are listening to 127.0.0.1, my /etc/hosts seems to be ok, I've got no interesting messages in /var/log/messages, nothing interesting in /home/admispconfig/ispconfig/ispconfig.log... And this isn't a new install..

I can tell ya what I did before the error started happening, I made an image of the server with systemimager and before I ran systemimager I turned off all non-critical services. Well, at least I didn't think they'd be critical during this backup. After the image was taken I rebooted and that was that.. Everything is fine that I can tell aside from the services not showing up as online except mysqld.

Thanks for your attention!

EDIT -- running a version of the script, /home/admispconfig/ispconfig/lib/plugins/check_services.plugin.php, modified to run a check is returning true.. I'm guessing it's a caching issue possibly?? Things are indeed working, it's just the web page displays Offline..


Code:
[root@main ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:imaps                     *:*                         LISTEN      1706/dovecot
tcp        0      0 *:pop3s                     *:*                         LISTEN      1706/dovecot
tcp        0      0 *:mgcp-callagent            *:*                         LISTEN      1559/sshd
tcp        0      0 localhost.localdomain:smux  *:*                         LISTEN      1541/snmpd
tcp        0      0 *:mysql                     *:*                         LISTEN      1671/mysqld
tcp        0      0 *:pop3                      *:*                         LISTEN      1706/dovecot
tcp        0      0 *:imap                      *:*                         LISTEN      1706/dovecot
tcp        0      0 *:http                      *:*                         LISTEN      2102/httpd
tcp        0      0 *:hosts2-ns                 *:*                         LISTEN      1915/ispconfig_http
tcp        0      0 main.tacticsoft.net:domain  *:*                         LISTEN      2231/named
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      2231/named
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      2231/named
tcp        0      0 *:smtp                      *:*                         LISTEN      2174/master
tcp        0      0 *:https                     *:*                         LISTEN      2102/httpd
Code:
[root@main ~]# telnet 127.0.0.1 80
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
show me
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
</p>
<hr>
<address>Apache/2.2.0 (Fedora) Server at main.tacticsoft.net Port 80</address>
</body></html>
Connection closed by foreign host.
Code:
[root@main ~]# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain localhost
82.103.140.19           main.tacticsoft.net tacticsoft.net tacticsoft main
Code:
05.06.2007 - 11:22:23 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/rc.d/init.d/bastille-firewall restart &> /dev/null
05.06.2007 - 11:22:26 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/rc.d/init.d/httpd restart &> /dev/null
05.06.2007 - 11:22:26 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /etc/rc.d/init.d/postfix stop &> /dev/null
05.06.2007 - 11:22:26 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/rc.d/init.d/postfix start &> /dev/null
05.06.2007 - 11:22:29 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/rc.d/init.d/named restart &> /dev/null
05.06.2007 - 11:22:29 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/rc.d/init.d/proftpd stop &> /dev/null

Last edited by xkworld; 5th June 2007 at 18:30.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP-Server: Offline sandman_ua Installation/Configuration 18 8th January 2007 15:52
ISP Services wouldn't restart any service, possibly Domain Host configuration issue. Kamran Shah Installation/Configuration 20 17th August 2006 17:33
Services doesn't work - a bug? tom Installation/Configuration 2 9th April 2006 13:10
Web Server Goes Offline kapatid Installation/Configuration 1 28th March 2006 10:16
Annoyance: Logout when going to Services IntnsRed General 2 14th December 2005 01:24


All times are GMT +2. The time now is 14:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.