Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2013, 10:46
zazuleac zazuleac is offline
Junior Member
 
Join Date: Aug 2008
Location: Ploiesti, Romania
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to zazuleac
Default ISPConfig 3.0.5.2 - no login, just fedora test page

Hi,

I've just setup a fresh install of fedora 15x64 + ISPConfig 3.0.5.2.

When I try entering admin interface of ispconfig (http(s)://<ip_address>:8080/) I get "fedora test page".

The only error I got on ISPConfig setup was:

"postalias: fatal: open /var/lib/mailman/data/aliases: No such file or directory"

the output of netstat -tap is:

Code:
[root@ns install]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:pop3                      *:*                         LISTEN      25235/dovecot
tcp        0      0 *:imap                      *:*                         LISTEN      25235/dovecot
tcp        0      0 *:sunrpc                    *:*                         LISTEN      938/rpcbind
tcp        0      0 *:42707                     *:*                         LISTEN      1032/rpc.statd
tcp        0      0 *:ssh                       *:*                         LISTEN      1102/sshd
tcp        0      0 *:smtp                      *:*                         LISTEN      25194/master
tcp        0      0 *:imaps                     *:*                         LISTEN      25235/dovecot
tcp        0      0 *:pop3s                     *:*                         LISTEN      25235/dovecot
tcp        0      0 localhost:10025             *:*                         LISTEN      25194/master
tcp        0      0 *:mysql                     *:*                         LISTEN      25061/mysqld
tcp        0      0 ns.unifast.ro:ssh           86.105.16.10:49911          ESTABLISHED 26253/sshd: root@no
tcp        0      0 ns.unifast.ro:ssh           86.105.16.10:64988          ESTABLISHED 22440/sshd: root@no
tcp        0      0 ns.unifast.ro:ssh           86.105.16.10:64978          ESTABLISHED 22417/sshd: root@no
tcp        0      0 ns.unifast.ro:ssh           86.105.16.10:64966          ESTABLISHED 22399/sshd: root@pt
tcp        0      0 *:pop3                      *:*                         LISTEN      25235/dovecot
tcp        0      0 *:imap                      *:*                         LISTEN      25235/dovecot
tcp        0      0 *:sunrpc                    *:*                         LISTEN      938/rpcbind
tcp        0      0 *:http                      *:*                         LISTEN      26166/httpd
tcp        0      0 *:ftp                       *:*                         LISTEN      1558/proftpd: (acce
tcp        0      0 *:ssh                       *:*                         LISTEN      1102/sshd
tcp        0      0 *:46840                     *:*                         LISTEN      1032/rpc.statd
tcp        0      0 *:smtp                      *:*                         LISTEN      25194/master
tcp        0      0 *:https                     *:*                         LISTEN      26166/httpd
tcp        0      0 *:imaps                     *:*                         LISTEN      25235/dovecot
tcp        0      0 *:pop3s                     *:*                         LISTEN      25235/dovecot
What am I doing wrong?
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2013, 10:58
tahunasky tahunasky is offline
Member
 
Join Date: Jul 2012
Location: Buenos Aires
Posts: 84
Thanks: 1
Thanked 8 Times in 8 Posts
Default

As you can see from the netstat output nothing is listening on port 8080.

So check that /etc/apache2/sites-available/ispconfig.vhost (probably /etc/httpd/... on fedora) exits and that there is a line saying to listen on port 8080 (or what every you use). It should look something like this:

Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>

Also check that there is a link to the above file in /etc/apache2/sites-enabled/000-ispconfig.vhost (probably /etc/httpd/... on fedora).

Manually stop and start apache and see if there is any errors and check the apache log file.

/etc/init.d/httpd stop
/etc/init.d/httpd start

Last edited by tahunasky; 15th May 2013 at 11:19.
Reply With Quote
  #3  
Old 15th May 2013, 11:09
zazuleac zazuleac is offline
Junior Member
 
Join Date: Aug 2008
Location: Ploiesti, Romania
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to zazuleac
Default

yes, the file (ispconfig.vhost) exists, it's located in /etc/httpd/conf/sites-available/, and it contains:

Code:
 Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
  ServerAdmin webmaster@localhost
......................
also manually stoped / started apache and still nothing happens.

LE:

the include line exists in httpd.conf :
[CODE]Include /etc/httpd/conf/sites-enabled/[CODE]
Reply With Quote
  #4  
Old 15th May 2013, 11:37
tahunasky tahunasky is offline
Member
 
Join Date: Jul 2012
Location: Buenos Aires
Posts: 84
Thanks: 1
Thanked 8 Times in 8 Posts
Default

Has SELinux been disabled ?
Reply With Quote
  #5  
Old 15th May 2013, 11:44
zazuleac zazuleac is offline
Junior Member
 
Join Date: Aug 2008
Location: Ploiesti, Romania
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to zazuleac
Default

yes, is disabled:

/etc/selinux/config:

Code:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

[root@ns install]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


LE:

I've checked apache's error log and found this:

[Wed May 15 14:25:45 2013] [error] [client 86.105.16.10] Directory index forbidden by Options directive: /var/www/html/

maybe it has something to do with that ...

Last edited by zazuleac; 15th May 2013 at 13:31.
Reply With Quote
  #6  
Old 15th May 2013, 14:23
zazuleac zazuleac is offline
Junior Member
 
Join Date: Aug 2008
Location: Ploiesti, Romania
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to zazuleac
Default

the error above, regarding "Directory index forbidden by Options directive: /var/www/html/" was because of the fresh install ... after i created a blank index.html, the error dissapeared.

Still not being able to login to ISPConfig admin. Now all I get is that blank page.

I've checked all the logs I can think of and no error.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 20:03
postfix problems kwickcut Installation/Configuration 6 5th March 2012 19:19
Lost the ISPConfig login page jopa123 Installation/Configuration 2 16th September 2010 22:10
ISPConfig 2 Roundcube blank page after login cripperz Installation/Configuration 4 4th November 2009 20:43
Login Screen Disappeared after installing ISPConfig in Fedora Core HACKERS PAL Installation/Configuration 3 17th June 2009 10:24


All times are GMT +2. The time now is 10:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.