#1  
Old 13th May 2013, 08:57
alecvannoten alecvannoten is offline
Junior Member
 
Join Date: Apr 2013
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default DNS problems

Hi,

something odd is happening:

I have a multiserver setup with ISPconfig 3.0.5.2 and Debian 6 on all servers

my master server (web01) which also acts to serve my own sites also holds the ISPconfig CP.

I have two DNS servers: dns01 and dns02, dns02 is a mirror of dns01.

I have multiple domains, for example domain1.be and domain2.com

when I edit settings (e.g. add a new A record/subdomain) for domain.be, all works fine and the DNS server takes over the new config and dns02 mirrors it perfectly.

BUT when I add a new A record for domain2.com the DNS servers don't take over the new configuration...

So it can't be a
- firewall issue
- connection to master DB issue

Also the option of max dns records is set to '-1' in the client template.

what to do?
Reply With Quote
Sponsored Links
  #2  
Old 13th May 2013, 09:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,006
Thanks: 826
Thanked 5,377 Times in 4,224 Posts
Default

Please see here:

http://www.howtoforge.com/forums/showthread.php?t=58408
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th May 2013, 09:28
alecvannoten alecvannoten is offline
Junior Member
 
Join Date: Apr 2013
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ok I read the post and did the following:

dig @ns1.alecvannoten.net test.alecvannoten.net

Code:
; <<>> DiG 9.7.6-P1 <<>> @ns1.alecvannoten.net test.alecvannoten.net
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40840
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;test.alecvannoten.net.		IN	A

;; AUTHORITY SECTION:
alecvannoten.net.	3600	IN	SOA	ns1.alecvannoten.net. hostmaster.alecvannoten.net. 2013051107 7200 540 1209600 10800

;; Query time: 24 msec
;; SERVER: 141.138.192.235#53(141.138.192.235)
;; WHEN: Mon May 13 09:19:51 2013
;; MSG SIZE  rcvd: 90
I waited long enough because the task was not in the jobqueue anymore.

than I did this http://www.faqforge.com/linux/debugg...-of-a-failure/
> no results/errors.

here are some excerpts from the syslog of the dns01 server

Code:
May 13 07:58:02 dns01 named[1166]: reloading configuration succeeded
May 13 07:58:02 dns01 named[1166]: reloading zones succeeded
May 13 07:58:02 dns01 named[1166]: dns_rdata_fromtext: /etc/bind/pri.alecvannoten.net:19: near '_caldav._tcp.': bad name (check-names)
May 13 07:58:02 dns01 named[1166]: zone alecvannoten.net/IN: loading from master file /etc/bind/pri.alecvannoten.net failed: bad name (check-names)
May 13 07:58:02 dns01 named[1166]: zone alecvannoten.net/IN: not loaded due to errors.
Code:
May 13 08:02:43 dns01 named[1166]: client 64.85.73.124#16414: query (cache) 'test.alecvannoten.net.sav.sea.dotster.net/A/IN' denied
May 13 08:03:01 dns01 /USR/SBIN/CRON[30283]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
May 13 08:03:49 dns01 named[1166]: client 64.85.73.124#2130: query (cache) 'test.alecvannoten.net.sav.sea.dotster.net/A/IN' denied
etc...

maybe the zonefile for alecvannoten.net is corrupt?

EDIT WITH NEW INFO:

I looked in the config file of alecvannoten.net at /etc/bind and this file is updated correctly whenever I change, delete, add... DNS records...

I stopped, restarded, reloaded config etc... Nothing happening?

Last edited by alecvannoten; 13th May 2013 at 09:35.
Reply With Quote
  #4  
Old 13th May 2013, 10:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,006
Thanks: 826
Thanked 5,377 Times in 4,224 Posts
Default

Line 13 of the file is wrong. Check the record that you added regarding caldav in ispconfig dns module of that zone, it is not correct so that bind refuses to load the zone.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 13th May 2013, 19:22
alecvannoten alecvannoten is offline
Junior Member
 
Join Date: Apr 2013
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

fixed, once again thanks Till!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dns problems via ISPCONFIG setup daseagle Installation/Configuration 2 12th March 2012 17:53
Problems with Monitor and DNS since upgrade drapsag General 22 8th March 2012 14:51
Still have problems with DNS nissy Installation/Configuration 11 7th September 2010 21:25
Reverse DNS problems K_meleonu Installation/Configuration 5 23rd November 2008 13:48
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51


All times are GMT +2. The time now is 05:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.