Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th May 2013, 18:59
counterpoint counterpoint is offline
Junior Member
 
Join Date: Jan 2010
Posts: 21
Thanks: 1
Thanked 5 Times in 5 Posts
Default Install bind9 debian wheezy chrooted

I've just attempted installation of bind9 into the newly released Debian Wheezy, following the squeeze howto.

When I got to the point of starting bind9 at the end, it failed with:

/etc/init.d/bind9: 5: /etc/default/bind9: bind: not found

I've studied the script, but cannot see what is wrong. Can anyone help with this?
Reply With Quote
Sponsored Links
  #2  
Old 8th May 2013, 19:58
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

What does the commandline say when you do

Code:
apt-get install bind9
Reply With Quote
  #3  
Old 8th May 2013, 21:37
counterpoint counterpoint is offline
Junior Member
 
Join Date: Jan 2010
Posts: 21
Thanks: 1
Thanked 5 Times in 5 Posts
Default

It says:

Reading package lists... Done
Building dependency tree
Reading state information... Done
bind9 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I followed the "how to" right through, starting with installing bind9, stopping it, moving files around and so on, right up to attempting to start bind9 again at the end. It's at this point I get the error.
Reply With Quote
  #4  
Old 8th May 2013, 22:49
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

I thought it might be an issue with your sources.lst, but it's not. It looks like it has been installed.

I'm not sure the problem, but you can try:

Code:
which bind9
or

Code:
whereis bind9
Those will just tell you the location of the install. I'm not sure why restart isn't working.


Falko told me to follow this installation howto for Wheezy, and I didn't have any issues: http://www.howtoforge.com/perfect-se...ot-ispconfig-3

Last edited by darinpeterson; 8th May 2013 at 22:51. Reason: explain location
Reply With Quote
  #5  
Old 8th May 2013, 22:54
counterpoint counterpoint is offline
Junior Member
 
Join Date: Jan 2010
Posts: 21
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Thanks - it would work, it just does the basic install of bind9 which is only the first step in the how-to that chroots bind. It's after the chroot install that the problem arises.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setup OpenQRM 4.7 with LXC Supprt in Debian Squeeze/Lenny zenny HOWTO-Related Questions 1 4th October 2010 13:46
Whats Needed for install of ispCP on a debian OS from scratch husskii Installation/Configuration 24 19th January 2010 02:07
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 00:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.