#1  
Old 12th August 2006, 17:27
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default Site with MySQL problem?!

I’ve created a site account with a MySQL database (with the use of ISPconfig).
The database name is: web15_db1 and the database user is: web15_u1. (I also enabled the "remote" option, and did set a password.)

When I access the server with "phpMyAdmin" I do see the database and user name, so this is all working fine.

Anyway.. Today I tried installing "phpBB2 Plus" (it's a forum), but for some reason it did not accept the user/database name!
The error I was getting is Client does not support authentication protocol requested by server; consider upgrading MySQL client
(I'm 100% sure the username and passwor that I used was correct)

The strange thing was that when I deleted and recreated the same user and same database again within "phpMyAdmin", I was still getting the same error!

I've now setup the forum with the root MySQL user and password :/

Anyone here who might know what could be wrong?
Does MySQL not exept users or databases with a "_"??

MySQL version is MySQL 4.1.11-Debian_4sarge5

PS.. I will try to recreate the error on a new test site later today.

Last edited by edge; 12th August 2006 at 18:27.
Reply With Quote
Sponsored Links
  #2  
Old 12th August 2006, 18:58
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Okay.. I found a fix..

Code:
Run mysql and login as root:
mysql -u root -p

mysql> SET PASSWORD FOR
    -> 'some_user'@'some_host' = OLD_PASSWORD('newpwd');
In my case the 'some_user' is web15_u1
The 'newpwd' is the password that you would like to use..
Reply With Quote
  #3  
Old 13th August 2006, 20:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Then phpBB seems to have a problem with MySQL 4.1 or something like that...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
postfix - MySQL connection problem epo Installation/Configuration 7 4th August 2006 21:49
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 03:53
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 17:04
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 17:37


All times are GMT +2. The time now is 19:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.