Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2013, 19:40
labsy labsy is offline
Junior Member
 
Join Date: Apr 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Cool php.ini, SMTP out and PEAR problems

Hi,
I have latest ISPConfig 3.0.5.2 installed with PHP Version 5.3.2-1ubuntu4.14. PHP is protected with the Suhosin Patch 0.9.9.1, and it is running as Fast-CGI on all websites.
I have some problems understanding, how to properly configure PHP, PEAR and SMTP.

First, I have SOME of 50 web sites running WITHOUT below problems, but the rest are having problems I describe below. I canot fugure out, where is the catch.

1.) ERROR when sending mail using PEAR:
Failed opening required 'Mail.php' (include_path='.:/usr/share/php') in /var/www/clients/client1/web11/web/index.php
The PHP script is exact copy of working script from another domain on the same server, but it does not work. PATH /usr/share/php is correct, permissions are 644 on all files.
Any idea?

2.) SMTP proxy
I have a special SMTP Antispam and antivirus proxy server, setup only for my web servers to send mail through it. On my Windows servers I have PHP.INI configured:
Code:
[mail functions]
SMTP = 1.2.3.4
smtp_port = 587
And it works fine.
But not on this Linux server - from mail.info log, that server is trying to contact destination SMTP directly.

I have edited PHP.INI in both locations:
/etc/php5/cgi/php.ini
/etc/php5/apache2/php.ini
Weird is, that when I print phpinfo(), I see only user-specific PHP is loaded:
Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /var/www/conf/web11/php.ini

Any idea what I am doing wrong?
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.