Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th April 2013, 00:04
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default Nginx cannot start a new site - vhost.err

Hello everybody! I recently have been discovering Nginx (coming from a all-in Apache user). Today was my first dive with ISPConfig + Nginx + PHP-FPM.

My problem was that after a successful installation rutine, ISPConfig's trigger to initiate the site's .vhost file failed. I kept seeing error messages in the log like:

Code:
WARNING - nginx did not restart after the configuration change for website DOMAIN_NAME Reverting the configuration. Saved non-working config as /etc/nginx/sites-available/DOMAIN_NAME.vhost.err
...and...

Code:
DEBUG - chmod failed: /var/www/clients/client#/web#/web/stats/.htpasswd_stats : 493
After tons of Googling, I found the solution to actually be to increase nginx's server_names_hash_bucket_size

I am posting this to help any future Googler find it X minutes faster than I did and support the community!
Reply With Quote
Sponsored Links
Reply

Bookmarks

Tags
ispconfig, nginx

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
apache cannot start after creating a new site orasis General 15 30th January 2013 11:38
The Perfect Server - Ubuntu 10.10 [ISPConfig 3] artifact66 Installation/Configuration 3 14th March 2011 13:06
Named hangs to start when I add new site loonies General 3 7th November 2008 09:08
apache wont start after deleting a site tellar Installation/Configuration 1 2nd October 2008 15:34
apache wont start after deleting a site tellar Installation/Configuration 2 1st October 2008 16:49


All times are GMT +2. The time now is 10:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.