Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th April 2013, 02:22
wlee1970 wlee1970 is offline
HowtoForge Supporter
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default ERROR: Connection dropped by IMAP server.

Hi all, have an issue, going to show my mail.log
Quote:
tail -n 15 /var/log/mail.log
Apr 6 20:10:03 fever dovecot: log: Warning: Killed with signal 15 (by pid=1 uid=0 code=kill)
Apr 6 20:10:08 fever dovecot: master: Dovecot v2.0.19 starting up (core dumps disabled)
Apr 6 20:10:16 fever dovecot: imap-login: Login: user=<cid>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=32473, secured
Apr 6 20:10:16 fever dovecot: imap(cid): Error: user cid: Initialization failed: mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/cid
Apr 6 20:10:16 fever dovecot: imap(cid): Error: Invalid user settings. Refer to server log for more information.
Apr 6 20:11:06 fever dovecot: imap-login: Login: user=<cid>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=32475, secured
Apr 6 20:11:06 fever dovecot: imap(cid): Error: user cid: Initialization failed: mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/cid
Apr 6 20:11:06 fever dovecot: imap(cid): Error: Invalid user settings. Refer to server log for more information.
Apr 6 20:11:28 fever postfix/smtps/smtpd[32480]: connect from localhost.localdomain[127.0.0.1]
Apr 6 20:11:54 fever dovecot: imap-login: Login: user=<cid>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=32486, secured
Apr 6 20:11:54 fever dovecot: imap(cid): Error: user cid: Initialization failed: mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/cid
Apr 6 20:11:54 fever dovecot: imap(cid): Error: Invalid user settings. Refer to server log for more information.
Apr 6 20:16:28 fever postfix/smtps/smtpd[32480]: SSL_accept error from localhost.localdomain[127.0.0.1]: Connection timed out
Apr 6 20:16:28 fever postfix/smtps/smtpd[32480]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Apr 6 20:16:28 fever postfix/smtps/smtpd[32480]: disconnect from localhost.localdomain[127.0.0.1]
I see an error about mail location and if so what can i do to fix it?

thanks
wlee1970
Reply With Quote
Sponsored Links
  #2  
Old 7th April 2013, 03:14
wlee1970 wlee1970 is offline
HowtoForge Supporter
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Now i am getting this error on squirrelmail

what is going on here?

Quote:
Apr 6 21:11:59 fever dovecot: auth: Fatal: Unknown database driver 'mysql'
Apr 6 21:11:59 fever dovecot: master: Error: service(auth): command startup failed, throttling
Apr 6 21:12:25 fever postfix/smtpd[3482]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
Apr 6 21:12:25 fever postfix/smtpd[3482]: connect from mail-we0-f175.google.com[74.125.82.175]
Apr 6 21:12:34 fever dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=3384, input bytes=0
Apr 6 21:12:35 fever postfix/smtpd[3482]: fatal: no SASL authentication mechanisms
Apr 6 21:12:36 fever postfix/master[2868]: warning: process /usr/lib/postfix/smtpd pid 3482 exit status 1
Apr 6 21:12:36 fever postfix/master[2868]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Apr 6 21:12:45 fever postfix/master[2868]: terminating on signal 15
Apr 6 21:12:47 fever postfix/master[3616]: daemon started -- version 2.9.6, configuration /etc/postfix
Apr 6 21:12:59 fever dovecot: auth: Fatal: Unknown database driver 'mysql'
Apr 6 21:12:59 fever dovecot: master: Error: service(auth): command startup failed, throttling
Apr 6 21:13:01 fever dovecot: pop3-login: Disconnected: Inactivity (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Apr 6 21:13:29 fever dovecot: imap-login: Error: Timeout waiting for handshake from auth server. my pid=3621, input bytes=0
Apr 6 21:13:59 fever dovecot: imap-login: Error: Timeout waiting for handshake from auth server. my pid=3621, input bytes=0
Apr 6 21:13:59 fever dovecot: auth: Fatal: Unknown database driver 'mysql'
Apr 6 21:13:59 fever dovecot: master: Error: service(auth): command startup failed, throttling
Apr 6 21:14:23 fever dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Apr 6 21:14:59 fever dovecot: auth: Fatal: Unknown database driver 'mysql'
Apr 6 21:14:59 fever dovecot: master: Error: service(auth): command startup failed, throttling

Last edited by wlee1970; 7th April 2013 at 03:19.
Reply With Quote
  #3  
Old 8th April 2013, 03:13
wlee1970 wlee1970 is offline
HowtoForge Supporter
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fixed it

I used Ubuntu guides to fix dovecot imap.

thanks
Reply With Quote
  #4  
Old 12th January 2014, 15:04
Jebakumar Jebakumar is offline
Junior Member
 
Join Date: Jan 2014
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi Weelee,

Can you post of the link of the ubuntu dovecot guide??
Reply With Quote
The Following User Says Thank You to Jebakumar For This Useful Post:
Ernestot (23rd January 2014)
  #5  
Old 12th January 2014, 15:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Accoding to the logs, the issu was most likely a missing dovecot-mysql package.

All our ubuntu guides are with dovecot, so I guess he used one of the guides listed here for the different ubuntu versions:

http://www.ispconfig.org/page/en/documentation.html
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
Virtual Users+Postfix+Courier+CentOS problem telnet localhost 25 stinson HOWTO-Related Questions 11 5th February 2011 13:57
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Can't Ping over VPN RoMiONeT Server Operation 2 4th July 2010 00:19
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59


All times are GMT +2. The time now is 08:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.