Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th March 2013, 13:15
horrorshow horrorshow is offline
Junior Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Cool ISPConfig 3.0.4.6 - Mail() does not route to remote MX when to domain on local server

Hi!

I hate to ask a question for my first post, but I have a route added to transport to google's IP. This is added under Advanced Email Routing. The domain uses google apps.

When I try to send an email using PHP's mail() function to any other email address, it works fine. When sending to an email address of a site on the local server, it tries to route it to localhost:

Mar 28 15:01:31 vds1 postfix/smtpd[582]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <work@xxxxxxxxxxx.com>: Recipient address rejected: User unknown in relay recipient table; from=<webmaster@xxxxxxxxxxx.com> to=<work@xxxxxxxxxxx.com> proto=ESMTP helo=<xxxxxxxxxxx.com>

Mar 28 15:01:31 vds1 sendmail[652]: r2SC1UVX000652: to=work@xxxxxxxxxxx.com, ctladdr=webmaster@xxxxxxxxxxx.com (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=30079, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown

The domain xxxxxxxxxxx.com is added as a site, but not a mail domain. Do I have this configured wrong, or is something else wrong? This is causing a form to not properly deliver emails.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 3rd April 2013, 07:57
bpmee bpmee is offline
Member
 
Join Date: Aug 2006
Posts: 86
Thanks: 3
Thanked 7 Times in 6 Posts
Default

Hi,

I don't have much experience with using Google to send and receive email with apps, but you might have to include Google's special SPF record inside your mailing domain's TXT record to send mail properly.

Google's SPF record for Apps is here.

From that page...

To create an SPF record for a domain:

Log in to the administrative console for your domain.

Locate the page from which you can update the DNS records. You may need to enable advanced settings.

Create a TXT record containing this text: v=spf1 include:_spf.google.com ~all

*(My note: this is NOT a separate TXT record if you already have one, just add the include:_spf.google.com part to your existing domain an ~all if necessary)

Publishing an SPF record that uses -all instead of ~all may result in delivery problems. See Google IP address ranges for details about the addresses for the Google Apps mail servers.

If your registrar also requires a host setting (such as @), see the TXT records for specific domain providers list for precise instructions.

Save your changes.

Keep in mind that changes to DNS records may take up to 48 hours to propagate throughout the Internet.
Reply With Quote
Reply

Bookmarks

Tags
googleapps, ispconfig, mail, php, postfix

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help cant access anything locally or from ip jimmie Installation/Configuration 14 5th March 2013 07:58
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 18:17
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33


All times are GMT +2. The time now is 14:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.