Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th March 2013, 01:59
kareemhali kareemhali is offline
Junior Member
 
Join Date: Dec 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't install Prestashop due to open_basedir error

Hi,

After upgrading ISPconfig, I can't install Prestashop on my server anymore. I get this error, which happens on step (Configure Shop Information at 58%).

[Mon Mar 25 00:40:51 2013] [warn] [client 82.37.187.108] mod_fcgid: stderr: PHP Warning: file_exists(): open_basedir restriction in effect. File(/var/www/clients/client1/web6/web/cms-shop/modules/error_log.txt/mails/en/) is not within the allowed path(s): (/var/www/clients/client1/web6/web:/var/www/clients/client1/web6/tmp:/var/www/mysite.com/web:/srv/www/mysite.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php) in /var/www/clients/client1/web6/web/cms-shop/classes/Tools.php on line 1264, referer: http://mysite.com/cms-shop/install/i...p?restart=true


I'm using Fast-CGI with SSL and SuEXEC ticked, and latest ISPconfig.

I tried setting file permissions, gave 777 to all files, didn't work. I tried putting directories in PHP open_basedir config on the site panel, didn't work, although I'm not sure if I put the correct directories.

When I disable it and put "none", installation works fine.

As I'm no PHP expert, I'm not sure if this is bad for the server to disable it completely or if it doesn't matter.

How can I fix it please?, also, what is the best settings on the site panel for a PrestaShop site.

Thanks,
Kareem.
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2013, 17:51
kareemhali kareemhali is offline
Junior Member
 
Join Date: Dec 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Any help ?

I thought by becoming a subscriber I would get more help to be honest !.

Kareem.
Reply With Quote
  #3  
Old 26th March 2013, 22:18
ressel ressel is offline
Senior Member
 
Join Date: Apr 2007
Location: Denmark
Posts: 128
Thanks: 18
Thanked 5 Times in 5 Posts
Default

try with
Code:
/var/www/clients/client1/web6/web:/var/www/clients/client1/web6/tmp:/var/www/mysite.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
I have installed a website with prestashop on one of my servers.
Reply With Quote
  #4  
Old 29th March 2013, 15:06
kareemhali kareemhali is offline
Junior Member
 
Join Date: Dec 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Thanks for the info, that didn't work!.

Kareem.

Quote:
Originally Posted by ressel View Post
try with
Code:
/var/www/clients/client1/web6/web:/var/www/clients/client1/web6/tmp:/var/www/mysite.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
I have installed a website with prestashop on one of my servers.
Reply With Quote
  #5  
Old 29th March 2013, 15:09
ressel ressel is offline
Senior Member
 
Join Date: Apr 2007
Location: Denmark
Posts: 128
Thanks: 18
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by kareemhali View Post
Hi,

Thanks for the info, that didn't work!.

Kareem.
I'm actually using suphp
Reply With Quote
  #6  
Old 30th March 2013, 05:48
kareemhali kareemhali is offline
Junior Member
 
Join Date: Dec 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Ressell,

I think Till recommends that we stick with Fast-CGI with SuEXEC ticked when using a CMS site.

I'm not sure why no one from ISPConfig team is replying to this post.

Anyway, thanks for your help Ressell.

Quote:
Originally Posted by ressel View Post
I'm actually using suphp
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xen for Centos 6.3 HowTo needs updating. Peter Williams HOWTO-Related Questions 24 28th January 2013 04:31
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 16:23
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 11:46
Error on install igbe Installation/Configuration 7 28th February 2007 23:55
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 04:38


All times are GMT +2. The time now is 10:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.