#1  
Old 4th March 2013, 21:50
servidoresadmin.com servidoresadmin.com is offline
Junior Member
 
Join Date: Nov 2012
Posts: 23
Thanks: 0
Thanked 2 Times in 2 Posts
Default Munin under nginx

Hello,

I usually runs munin under apache and it's installation is very easy. There's a howto and only four steps is needed.

Do you know if there's a howto to install munin under nginx on ispconfig 3 under debian?

Very thanks,

Servidores administrados
Reply With Quote
Sponsored Links
  #2  
Old 5th March 2013, 15:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

You can set up an alias in your vhost configuration like this:

Code:
                location /munin {
                       alias /var/cache/munin/www;
                       auth_basic "Restricted";
                       auth_basic_user_file /var/cache/munin/.htpasswd;
                       location ~* ^/munin/(.+\.(jpg|jpeg|gif|css|png|js|ico|xml|txt))$ {
                                alias /var/cache/munin/www/$1;
                       }
                }
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th March 2013, 16:23
servidoresadmin.com servidoresadmin.com is offline
Junior Member
 
Join Date: Nov 2012
Posts: 23
Thanks: 0
Thanked 2 Times in 2 Posts
Default It is not running

Hi Falko,

Thanks for your reply, but it is not running. I think there's a bad symbol on code, but this is not runnig, u receive error 500 under nginx:

location /munin {
alias /var/cache/munin/www;
auth_basic "Restricted";
auth_basic_user_file /var/cache/munin/.htpasswd;
location / { ^/munin/(.+\.(jpg|jpeg|gif|css|png|js|ico|xml|txt))$ {
alias /var/cache/munin/www/$1;
}
}

After uptating location / {

It is not running:

500 Internal Server Error
nginx/1.2.7

Thanks,
Servidores administradoshttp://www.servidoresadmin.com

Last edited by servidoresadmin.com; 5th March 2013 at 16:24. Reason: give thanks
Reply With Quote
  #4  
Old 6th March 2013, 00:36
servidoresadmin.com servidoresadmin.com is offline
Junior Member
 
Join Date: Nov 2012
Posts: 23
Thanks: 0
Thanked 2 Times in 2 Posts
Default Finally solved and running

Hi, Falko,

Finally I solved and now it's running:

Under Ispconfig | Domain| Options | nginx Directives:

______________________________________________

location /munin/ {
alias /var/cache/munin/www/;
index index.html;
}
______________________________________________

It's up and running now.

Thanks,

Servidores Dedicados Administrados
Reply With Quote
Reply

Bookmarks

Tags
debian, ispconfig, munin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
permission issues with ISPConfig3, nginx and cakephp ItsDom Installation/Configuration 2 30th December 2012 13:18
nginx Reverse Proxy on Separate Server from Apache atjensen11 HOWTO-Related Questions 2 8th September 2012 22:26
A Working Nginx Catchall with ISPConfig 3. renders Tips/Tricks/Mods 4 15th April 2011 21:53
Nothing Output from Munin mdittmer Installation/Configuration 5 13th January 2009 14:10
I moved munin, now i'm screwed jdkullmann HOWTO-Related Questions 9 24th May 2008 12:41


All times are GMT +2. The time now is 09:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.