Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th February 2013, 23:33
PC Networks PC Networks is offline
Junior Member
 
Join Date: Feb 2013
Location: Anza, CA
Posts: 9
Thanks: 8
Thanked 0 Times in 0 Posts
Send a message via ICQ to PC Networks Send a message via AIM to PC Networks Send a message via Yahoo to PC Networks
Post No PHP MySQL functions available Warning while Installaing ISPConfig3

Hello HTF users and moderators...

Working with a clean installation and the HowTo:The Perfect Server - Ubuntu 12.10

32bit machine


I have worked through the HT and got snagged on the end portion involving the installation of ISPConfig3.


PHP Version:
Code:
5.4.11



Code:
php-mysql
INSTALLED



PHP Installation Method: FastCGI


After running
Code:
php -q install.php
ISPConfig3 installation starts, and I am able to provide Language, Method, and FQDN


Then ISPConfig3 install complains:
Code:
No PHP MySQL functions available. Please ensure that the PHP MySQL module is loaded.
Output of: netstat -tap | grep mysql



Code:
tcp        0      0 *:mysql                 *:*                     LISTEN      1230/mysqld
I have searched the HTF community and located a few complaints of the same issue from users utilizing different HTF Perfect Server solutions which involves the use of ISPCOnfig3, anything suggested in those posts I have tried with failure though.

Thanking you in advance for your help
Reply With Quote
Sponsored Links
  #2  
Old 7th February 2013, 10:33
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,169
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

The Ubuntu php mysql package is named php5-mysql and not php-mysql. Please install all packages as described in the guide.

To install the missing package, run:

apt-get install php5-mysql
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
PC Networks (7th February 2013)
  #3  
Old 7th February 2013, 17:02
PC Networks PC Networks is offline
Junior Member
 
Join Date: Feb 2013
Location: Anza, CA
Posts: 9
Thanks: 8
Thanked 0 Times in 0 Posts
Send a message via ICQ to PC Networks Send a message via AIM to PC Networks Send a message via Yahoo to PC Networks
Angry php5-mysql Was Installed, Just My Omission During Original Post for Support

Simply an omission on my behalf during the original post.

Code:
php5-mysql
IS installed...

Below you will find this mornings output after attempting to install
Code:
ph5-mysql
again.

Code:
root@pcnetwork:~# apt-get install php5-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
php5-mysql is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reply With Quote
  #4  
Old 9th February 2013, 09:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

5.4.11 is a really new PHP version. I doubt it was installed through apt - I guess it was built manually, and MySQL support was left out.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
PC Networks (10th February 2013)
  #5  
Old 10th February 2013, 05:51
PC Networks PC Networks is offline
Junior Member
 
Join Date: Feb 2013
Location: Anza, CA
Posts: 9
Thanks: 8
Thanked 0 Times in 0 Posts
Send a message via ICQ to PC Networks Send a message via AIM to PC Networks Send a message via Yahoo to PC Networks
Wink

Hey Falko

Thanks for the reply.

Yeah when I did the installation I went to php.net and looked over their downloads page and was ONLY able to locate 5.4.11.
http://www.php.net/downloads.php

I installed php 5.4.11 VIA wget

Should I uninstall php 5.4.11 or what might you suggest?

Thank you Falko
Best Regards
Reply With Quote
  #6  
Old 12th February 2013, 11:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must recompile it, but with MySQL support.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
PC Networks (13th February 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Huge Problems after release upgrade sheshes Installation/Configuration 4 8th September 2012 19:44
Problem with ispconfig 3 staff007 Installation/Configuration 4 10th October 2011 21:17
MySQL Error Nolan Installation/Configuration 12 16th February 2011 02:15
Need help setting up domainpop with postfix kameelperdza Installation/Configuration 6 15th June 2009 07:49
[Postfix] Quota doesn't work krzysiek HOWTO-Related Questions 8 2nd March 2009 15:57


All times are GMT +2. The time now is 11:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.