#1  
Old 6th February 2013, 19:40
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default generic mail problem

Running Debian Squeeze, perfect server with ISPCFG3, brand new server, currently busy setting it up and all of a sudden I've got a couple of email problems. My guess is that it is MYSQL related? Please have a look at this partial log, I think its MYSQL but unsure where to start debugging:

I found a few similar threads and the suggestion was to try if the credentials


Code:
mail.warn
Feb  6 00:01:50 h2118175 postfix/cleanup[22145]: warning: 466874241DD: virtual_alias_maps map lookup problem for ovidiu@pacura.ru
Feb  6 00:01:50 h2118175 postfix/cleanup[22145]: warning: 469E74241DD: virtual_alias_maps map lookup problem for postmaster@h2118175.stratoserver.net
Feb  6 00:01:50 h2118175 amavis[5825]: (05825-13) (!)FWD via SMTP: <root@h2118175.stratoserver.net> -> <ovidiu@pacura.ru>,BODY=7BIT 451 4.3.0 TempFailed, id=05825-13, from MTA([127.0.0.1]:10025): 451 4.3.0 Error: queue file write error
Feb  6 00:01:50 h2118175 postfix/smtp[22148]: warning: mysql query failed: MySQL server has gone away
Feb  6 00:01:50 h2118175 postfix/smtp[22148]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Feb  6 00:01:51 h2118175 postfix/qmgr[3890]: warning: private/amavis socket: malformed response
Feb  6 00:01:51 h2118175 postfix/qmgr[3890]: warning: transport amavis failure -- see a previous warning/fatal/panic logfile record for the problem description
Feb  6 00:01:51 h2118175 postfix/master[3887]: warning: process /usr/lib/postfix/smtp pid 22148 exit status 1
Feb  6 00:20:18 h2118175 postgrey[3911]: Couldn't unlink "/var/run/postgrey.pid" [Permission denied]
Feb  6 00:20:18 h2118175 dovecot: dovecot: Killed with signal 15 (by pid=818 uid=0 code=kill)
Feb  6 09:02:29 h2118175 postfix/smtpd[21207]: warning: 62.245.48.3: hostname 3.48-245-62.FTTH.rus-com.net verification failed: Name or service not known
Feb  6 13:02:34 h2118175 postfix/smtpd[26679]: warning: 177.131.173.60: hostname 177-133-173-60.cliente.sumicity.com.br verification failed: Name or service not known
Feb  6 15:16:36 h2118175 dovecot: dovecot: Killed with signal 15 (by pid=30903 uid=0 code=kill)
Feb  6 15:16:36 h2118175 postgrey[4137]: Couldn't unlink "/var/run/postgrey.pid" [Permission denied]
Code:
mail.err
Feb  5 15:46:03 h2118175 postfix/trivial-rewrite[10955]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Feb  6 00:01:50 h2118175 postfix/smtp[22148]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
btw. I tried: mysql -u ispconfig -pXXX and it worked while XXX being the password inside: /etc/postfix/mysql-virtual_domains.cf

Its not the limits on MYSQL connections because I checked: [OK] Highest usage of available connections: 22% (22/100)

Any other suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 6th February 2013, 20:25
florian030 florian030 is offline
Senior Member
 
Join Date: Oct 2012
Posts: 221
Thanks: 8
Thanked 62 Times in 53 Posts
Default

maybe just a broken table.

what shows?

mysqlrepair -c --database DATABASE
?
__________________
regards
Florian

blog.schaal-24.de
Reply With Quote
  #3  
Old 7th February 2013, 00:09
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

I didn't know which DATABASE to check so I checked all. All showed either OK or simply no output to the command: mysqlrepair -c --database DATABASE

Lets see if that changed anything but I doubt it.
Reply With Quote
  #4  
Old 8th February 2013, 11:20
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

SOLVED: it was my fault, my MYSQL wait_timeout variable was set too low.
Reply With Quote
Reply

Bookmarks

Tags
amavis, dovecot, mysql, postfix, problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
procmail can't write Hellbound General 27 8th June 2009 21:51
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 06:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.