#1  
Old 4th February 2013, 10:11
onastvar onastvar is offline
Senior Member
 
Join Date: Apr 2008
Location: U.S.A.
Posts: 192
Thanks: 61
Thanked 12 Times in 12 Posts
Default Roundcube, ISPConfig, Nginx

Hi,

I've decided to try roundcube instead of squirrelmail. Installed Roundcube in subfolder /webmail under domain1.com (/var/www/clients/client0/web1/web/webmail/) webmail is currently accessible via http://domain1.com/webmail/

I can login with any email account and it works fine. I'm trying to find out how can I make it available under other domains.

1) Right now I can only access webmail via http://domain1.com/webmail/
I'd like to make it accessible via http://webmail.domain1.com

2) I cannot access webmail under other domains

http://domain2.com/webmail/
http://domain3.com/webmail/
http://domain4.com/webmail/

I'm not sure how to make this work. I know it's possible. Do I need to add code to NGINX Directives under each site? Anyone have similar setup, please advise?

Thank You!
__________________
ISPConfig 3.0.5.4p5 | Debian Wheezy | BIND | Dovecot 2.1.7 | Apache 2.2.22 | MySQL 5.5.38 | PHP 5.3.22
Reply With Quote
Sponsored Links
  #2  
Old 5th February 2013, 00:39
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
Default

You can install roundcube using the apps vhost, so every user can access roundcube (or everything you install there) in this way:

domain1.com:8081/roundcube
domain2.com:8081/roundcube

Software installed in the apps directory /var/www/apps must be owned by the user and group ispapps

Please note that /var/www/apps is the location in debian/ubuntu and I can't assume the location in centos for example.

Another option is create the subdomain webmail for each domain and redirect it to the desired location.

Cheers!
Reply With Quote
The Following User Says Thank You to pititis For This Useful Post:
onastvar (5th February 2013)
  #3  
Old 5th February 2013, 07:44
onastvar onastvar is offline
Senior Member
 
Join Date: Apr 2008
Location: U.S.A.
Posts: 192
Thanks: 61
Thanked 12 Times in 12 Posts
Default

That approach worked - Thank You Pititis!
__________________
ISPConfig 3.0.5.4p5 | Debian Wheezy | BIND | Dovecot 2.1.7 | Apache 2.2.22 | MySQL 5.5.38 | PHP 5.3.22
Reply With Quote
  #4  
Old 14th February 2013, 19:31
onastvar onastvar is offline
Senior Member
 
Join Date: Apr 2008
Location: U.S.A.
Posts: 192
Thanks: 61
Thanked 12 Times in 12 Posts
Default

When I go to subdomain http://webmail.mydomain.com
everything works fine as soon as RoundCube loads I see this in my URL

http://mydomain.com:8081/roundcube/index.php

How could I setup http://webmail.mydomain.com to display all the time, when I am in my webmail (roundcube)?
__________________
ISPConfig 3.0.5.4p5 | Debian Wheezy | BIND | Dovecot 2.1.7 | Apache 2.2.22 | MySQL 5.5.38 | PHP 5.3.22
Reply With Quote
  #5  
Old 14th February 2013, 22:10
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,270
Thanks: 84
Thanked 25 Times in 21 Posts
Default

I'm very much interested in this too. Currently I use this nginx location:

Quote:
location /webmail {
root /var/www/;
index index.php index.html index.htm;
location ~ ^/webmail/(.+\.php)$ {
try_files $uri =404;
root /var/www/;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_scrip$
include /etc/nginx/fastcgi_params;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 4k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;
}
location ~* ^/webmail/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|t$
root /var/www/;
}
}
BUT I need to have a subdomain webmail pointing to /var/www/webmail for the simple reason that for most of my domains use CloudFlare (the free version which doesn't support HTTPS) and so I can't enable HTTPS for domain.tld only for i.e. webmail.domain.tld and bypass CloudFlare for that subdomain.

Any ideas on how to do this with ISPCFG3+nginx?
Reply With Quote
  #6  
Old 15th February 2013, 19:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Create a new vhost (webmail.example.com) and add your directives to the nginx directives field. Inside the location block, you add

Code:
root /var/www/webmail;
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following 2 Users Say Thank You to falko For This Useful Post:
onastvar (20th February 2013), Ovidiu (16th February 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 19:10
RoundCube 0.6 on IspConfig 2 clixclix Tips/Tricks/Mods 2 8th August 2012 21:27
ubuntu VPS running ISPconfig + nginx 1gb ram 100% iain17 General 1 3rd June 2012 18:31
No dns zone files created? sjau Installation/Configuration 7 13th March 2012 14:15
A Working Nginx Catchall with ISPConfig 3. renders Tips/Tricks/Mods 4 15th April 2011 22:53


All times are GMT +2. The time now is 09:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.