Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th January 2013, 04:38
atjensen11 atjensen11 is offline
Senior Member
 
Join Date: Dec 2007
Posts: 199
Thanks: 9
Thanked 6 Times in 6 Posts
Default Moving RAID with LVM between Physical Machines

I have two identical phsyical machines in respect to hardware. I have already migrated all of my services from the one machine to the new production machine.

I am now migrating my backup device which is an external RAID enclosure connected via eSATA.

Within the RAID enclosure are currently three drives configured in a RAID5 array. I have successfully moved the enclosure over to the new production machine and have restored the array within mdadm.

The problem I am struggling with is accessing the data on the RAID5 array as I had LVM on top of the RAID.

I tried using a pvcreate command and I obtained the following error:

Code:
root@host1:/mnt# pvcreate /dev/md1
  Can't initialize physical volume "/dev/md1" of volume group "lvm-backup" without -ff
root@host1:/mnt# pvcreate -ff /dev/md1
Really INITIALIZE physical volume "/dev/md1" of volume group "lvm-backup" [y/n]? n
  /dev/md1: physical volume not initialized
I tried using Google and the pvcreate help to see what the -ff option is really doing. However, I didn't find any great help.

There are two logical volumes, each 500 GB on the lvm-backup volume group.

How can I successfully incorporate these into my existing LVM setup?

Thanks,
Tom
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed during pvmove, howto: set up software raid 1 on running LVM system sbh77 HOWTO-Related Questions 2 8th October 2010 00:11
Adding non-RAID backup disk to system with RAID 1... BorderAmigos Installation/Configuration 1 20th February 2010 20:50
Ubuntu 8.04 LTS - RAID 1 + LVM + XEN atjensen11 HOWTO-Related Questions 1 20th January 2009 20:35
Unable to repair/re-install ubunt svr ubuntu 8.04/8.10 on RAID 5 LVM lucy_t Installation/Configuration 5 19th December 2008 20:59
debian, lvm, raid, grub, custom kernel koi Installation/Configuration 4 3rd November 2007 10:39


All times are GMT +2. The time now is 15:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.