#1  
Old 14th December 2012, 22:24
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default How to test DNS?

Is there a way to test internally if the DNS server is working properly. I did http://www.intodns.com/lampxserver.com and have nameserver issues.

My router is forwarding port 53 to ns1 and these are my DNS settings:
Code:
Yes A lampxserver.com. 67.191.52.236 0  
Yes A mail 67.191.52.236 0  
Yes A www 67.191.52.236 0  
Yes MX lampxserver.com. mail1.lampxserver.com. 10  
Yes NS lampxserver.com. ns1.lampxserver.com. 0  
Yes NS lampxserver.com. ns2.lampxserver.com. 0
Reply With Quote
Sponsored Links
  #2  
Old 15th December 2012, 00:01
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

I figured out that my nameserver are not being resolved internally, how can I fix this... I changed the IP address of the hostname ns1.lampxserver.com to 192.168.10.151 and it now works... Why does it not resolve the internal IP?
Reply With Quote
  #3  
Old 15th December 2012, 10:41
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

you can try dig from localhost to extern IP
Reply With Quote
  #4  
Old 15th December 2012, 16:53
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

Does anyone have any mapping guides to go by to efficiently map DNS records to internal server.
Reply With Quote
  #5  
Old 15th December 2012, 19:07
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

One problem I am trying to figure out. Or rather a few problems:

I have my phpmyadmin on my db1 server running an apache instance.
I wish to make ispconfig on the panel server connecter to the phpmyadmin on the db server, how can I do that. one method I tried was:

First removing the /phpmyadmin from ispconfig server configuration then.
Using ssh to open the panel server that has the ispconfig web shell
Code:
nano /usr/local/ispconfig/interface/web/sites/database_phpmyadmin.php


    if($global_config['phpmyadmin_url'] != '') {
        $phpmyadmin_url = $global_config['phpmyadmin_url'];
        $phpmyadmin_url = str_replace('[SERVERNAME]',$serverData['server_name'],$phpmyadmin_url);
        header('Location:'.$phpmyadmin_url);
    } else {
        isset($_SERVER['HTTPS'])? $http = 'https' : $http = 'http';
        $http = 'http'; : just insert this line exactly here.
        if($web_config['server_type'] == 'nginx') {
            header('location:' . $http . '://' . $serverData['server_name'] . ':8081/phpmyadmin');
        } else {
            header('location:' . $http . '://' . $serverData['server_name'] . '/phpmyadmin');
        }
    }
I added the $http = 'http'; then I created an A record for db1 to the internal IP address of the database server which was called db1.domain_name.com

That of course did not work internally on the network or externally.

How can I correct this?
Reply With Quote
  #6  
Old 17th December 2012, 04:08
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

I have a glue record for my domain lampxserver.com but when I create the site and add the DNS records it does not work, here are the results:
http://www.intodns.com/lampxserver.com

But another domain using the same Nameservers ns1.lampxserver.com and ns2.lampxserver.com works fine:
http://www.intodns.com/ahostgroup.com

using the same DNS record settings... Am I not able to use the domain of my name servers? or how can I fix this.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dns & uribl DrJohn Server Operation 1 15th October 2011 18:13
ispconfig and dns. 2 questions. DNS guru wanted chachdog Installation/Configuration 3 15th July 2007 13:13
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52
DNS Issues Alam Installation/Configuration 3 11th November 2006 13:57
Pri & Slave DNS HOWTO (FC4) ppettigrew Suggest HOWTO 0 1st April 2006 15:35


All times are GMT +2. The time now is 18:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.