Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd December 2012, 16:03
lollollollol lollollollol is offline
Member
 
Join Date: Nov 2011
Location: Madagascar
Posts: 44
Thanks: 7
Thanked 6 Times in 5 Posts
Default ispconfig3 on Debian7 problem with suphp

Hello,
I'm fighting with ispconfig (ISPConfig-3.0.4.6) & suphp for a moment...

I'm starting from a fresh install of Debian testing (I know it's the testing branch) and I followed (as usually: this is at least my twentieth install on Debian stable) this tuto: http://www.howtoforge.com/perfect-se...ot-ispconfig-3

And I'm not abble to join the ispconfig panel...

tail -f /var/log/suphp/suphp.log
Code:
[Sun Dec 02 15:30:29 2012] [warn] Script "/usr/local/ispconfig/interface/web/index.php" resolving to "/usr/local/ispconfig/interface/web/index.php" not within configured docroot
I tried to add the path to /etc/suphp/suphp.conf, but it doesn't work...
Code:
[Sun Dec 02 15:32:03 2012] [warn] Directory "/usr/local" is writeable by group
I chowned 755 but i only obtain this...
Code:
[Sun Dec 02 15:38:53 2012] [warn] Script "/usr/local/ispconfig/interface/web/js/scrigo.js.php" resolving to "/usr/local/ispconfig/interface/web/js/scrigo.js.php" not within configured docroot
If I exclude /usr/local/ispconfig from /etc/apache2/mods-enabled/suphp.conf I can not run php index:
Code:
    <Directory /usr/local/ispconfig>
        suPHP_Engine off
    </Directory>

I'm not on the right way...
If someone could give me some leads to follow, I would be very grateful!

Last edited by lollollollol; 2nd December 2012 at 16:08. Reason: ispconfig version
Reply With Quote
Sponsored Links
  #2  
Old 3rd December 2012, 06:16
lollollollol lollollollol is offline
Member
 
Join Date: Nov 2011
Location: Madagascar
Posts: 44
Thanks: 7
Thanked 6 Times in 5 Posts
Default

Hi,
I managed to arrange with suphp.conf (the one in the /etc/suphp directory).
I just added a wildcard to the end of the path.
I was forced to "chmoded" (755) /usr/local.

I do not understand why in this installation I was forced to do this manipulations. I installed IspConfig dozens of times, and I never faced this problem.

Remains the consequences of chmod 755 /usr/local: it is not the Debian way for a directory... I do not know what it will produce as a side effect...

Remains in my logs hundreds of lines of this type, but it must be another problem...
Code:
[Mon Dec 03 05:30:07 2012] [error] [client xx.xx.xx.xx] PHP Strict Standards:  Non-static method SimplePie_Parse_Date::get() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 10870, referer: https://mydomain.tld:8080/index.php
If some kind soul has an explanation, (s)he is welcome... (literal translation of a French-speaking)...

Laurent.
Reply With Quote
  #3  
Old 3rd December 2012, 09:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

The ispconfig interface should not be run with suphp. My guess is that suphp is enabled globally by accident on your server. Edit the suphp.conf file in /etc/apache2/mods-available and remove any addtype and addhandler lines that you find there. Then restart apache and undo the changes you described above.

Quote:
Remains in my logs hundreds of lines of this type, but it must be another problem...
Which ispconfig version do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
lollollollol (3rd December 2012)
  #4  
Old 3rd December 2012, 12:59
lollollollol lollollollol is offline
Member
 
Join Date: Nov 2011
Location: Madagascar
Posts: 44
Thanks: 7
Thanked 6 Times in 5 Posts
Default

Hi Till,
Thank you very much for putting me on the right path, this is actually the configuration of the suphp module that was a problem in apache. Your mastery is impressive!

Here is the suphp configuration in Wheezy (Debian 7) 0.7.1-3:
Code:
<IfModule mod_suphp.c>
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler application/x-httpd-suphp
    </FilesMatch>
       suPHP_AddHandler application/x-httpd-suphp

    <Directory />
        suPHP_Engine on
    </Directory>

    # By default, disable suPHP for debian packaged web applications as files
    # are owned by root and cannot be executed by suPHP because of min_uid.
    <Directory /usr/share>
        suPHP_Engine off
    </Directory>

# # Use a specific php config file (a dir which contains a php.ini file)
#       suPHP_ConfigPath /etc/php5/cgi/suphp/
# # Tells mod_suphp NOT to handle requests with the type <mime-type>.
#       suPHP_RemoveHandler <mime-type>
</IfModule>
And the suphp configuration in Debian Squeeze 0.7.1-1:
Code:
<IfModule mod_suphp.c>
        AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
        suPHP_AddHandler application/x-httpd-suphp

    <Directory />
        suPHP_Engine on
    </Directory>

    # By default, disable suPHP for debian packaged web applications as files
    # are owned by root and cannot be executed by suPHP because of min_uid.
    <Directory /usr/share>
        suPHP_Engine off
    </Directory>

# # Use a specific php config file (a dir which contains a php.ini file)
#       suPHP_ConfigPath /etc/php4/cgi/suphp/
# # Tells mod_suphp NOT to handle requests with the type <mime-type>.
#       suPHP_RemoveHandler <mime-type>
</IfModule>
I first copied the suphp.conf Squeeze on my Wheezy. And it worked. But as it is not very "clean", I downgraded libapache2-mod-suphp. Everything is back in order.

I think we need to think about it when Wheezy will becomes stable...

For the SimplePie_Misc problem:
Quote:
Originally Posted by till
Which ispconfig version do you use?
Quote:
Originally Posted by lollollollol
ISPConfig-3.0.4.6
Thank you in advance.
Reply With Quote
  #5  
Old 3rd December 2012, 14:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Hi,

I guess all you have to do on debian 7 is to change the lines:

<FilesMatch "\.ph(p3?|tml)$">
SetHandler application/x-httpd-suphp
</FilesMatch>
suPHP_AddHandler application/x-httpd-suphp

to:

<FilesMatch "\.ph(p3?|tml)$">
# SetHandler application/x-httpd-suphp
</FilesMatch>
# suPHP_AddHandler application/x-httpd-suphp
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 4th December 2012, 12:16
lollollollol lollollollol is offline
Member
 
Join Date: Nov 2011
Location: Madagascar
Posts: 44
Thanks: 7
Thanked 6 Times in 5 Posts
Default

Hello Till,

That's what I first done; But I don't like to modify conf.
It's more easy to use apt-get install libapache2-mod-suphp/stable

Anyway, it will be a point to watch when wheezy will be stable (and when a lot a people will try to upgrade...).

Thanks a lot for your help.

Laurent.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13 MrCompTech Tips/Tricks/Mods 8 25th August 2014 14:18
SuPHP in ISPConfig3 Captain Installation/Configuration 3 7th June 2012 13:58
SugarCRM Install on ISPConfig3 w/ SuPHP clucena Installation/Configuration 1 9th February 2010 09:29
Problem installing and configuring suPHP on Debian 4.0 Etch DirtyMonkey Installation/Configuration 5 2nd October 2008 12:18


All times are GMT +2. The time now is 21:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.