Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st December 2012, 11:24
Vamiris Vamiris is offline
Junior Member
 
Join Date: Dec 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Alias Domains creating Trailing Slash

Hello,

using Alias Domains, ISP Config creates vhosts like this:

RewriteRule ^/(.*)$ http://www.domain.de/folder/file.html/$1
RewriteCond %{HTTP_HOST} ^www.aliasdomain.de$ [NC]


How can I get rid off of the trailing slash at the end?

In the Backend, I use an Alias Domain, Redirect no flag to http://www.domain.de/folder/file.html

Auto Subdomain is www

Kind Regards
Christian
Reply With Quote
Sponsored Links
  #2  
Old 3rd December 2012, 09:55
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

The redirect feature is for redirects to directries only, so a slash is added automatically. This is required for security.

If you want to add redirects to files, then add the redierct rules into a.htaccess file of the site or in the apache directives field of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
post fix error after a year aberrio Server Operation 5 5th May 2009 21:33
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 09:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.