Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd August 2006, 20:27
Sarcha Sarcha is offline
Junior Member
 
Join Date: Aug 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Outgoing email problems

I have just recently setup a new server following the Prefect Setup guide for Fedora Core 5. I then installed ISPConfig per the intructions provided. I am able to recieve mail from outside and send mail internally. I just cannot send out to any other domains. When I try to send out I get an email back with
The following recipient(s) cannot be reached:
'service@advcomputers.com' on 8/2/2006 12:34 PM
550 <service@advcomputers.com>: Recipient address rejected: User unknown in local recipient table

Some of the other email I send to hotmail addresses never arrives and no messages come back.

My mail log file looks like this...

Aug 2 12:32:44 ns1 postfix/qmgr[12302]: 1A0DD834415: from=<scott@advcomputers.ca>, size=2688, nrcpt=1 (queue active)
Aug 2 12:32:45 ns1 postfix/master[12299]: warning: process /usr/libexec/postfix/smtp pid 12304 exit status 1
Aug 2 12:32:45 ns1 postfix/master[12299]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 2 12:33:32 ns1 postfix/smtpd[12323]: warning: connect to private/tlsmgr: Connection refused
Aug 2 12:33:32 ns1 postfix/smtpd[12323]: warning: problem talking to server private/tlsmgr: Connection refused
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: warning: connect to private/tlsmgr: Connection refused
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: warning: problem talking to server private/tlsmgr: Connection refused
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: warning: no entropy for TLS key generation: disabling TLS support
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: connect from unknown[10.10.10.5]
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: AEA7A834417: client=unknown[10.10.10.5], sasl_method=PLAIN, sasl_username=web1_scott
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: AEA7A834417: reject: RCPT from unknown[10.10.10.5]: 550 <service@advcomputers.com>: Recipient address rejected: User unknown in local recipient table; from=<scott@advcomputers.ca> to=<service@advcomputers.com> proto=ESMTP helo=<TECHSHOP>
Aug 2 12:33:33 ns1 postfix/cleanup[12325]: AEA7A834417: message-id=<000801c6b651$64ebf7b0$2ec3e710$@ca>
Aug 2 12:33:33 ns1 postfix/qmgr[12302]: AEA7A834417: from=<scott@advcomputers.ca>, size=2718, nrcpt=1 (queue active)
Aug 2 12:33:38 ns1 postfix/smtpd[12323]: disconnect from unknown[10.10.10.5]
Aug 2 12:33:45 ns1 postfix/smtp[12331]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 2 12:33:46 ns1 postfix/master[12299]: warning: process /usr/libexec/postfix/smtp pid 12331 exit status 1
Aug 2 12:33:46 ns1 postfix/master[12299]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 2 12:34:46 ns1 postfix/smtp[12352]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 2 12:34:47 ns1 postfix/master[12299]: warning: process /usr/libexec/postfix/smtp pid 12352 exit status 1
Aug 2 12:34:47 ns1 postfix/master[12299]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 2 12:35:12 ns1 dovecot: pop3-login: Login: user=<web1_scott>, method=PLAIN, rip=::ffff:10.10.10.5, lip=::ffff:10.10.10.1
Aug 2 12:35:12 ns1 dovecot: POP3(web1_scott): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0

My main.cf file looks like this...

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtp_sasl_local_domain =
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

Any help with this problem would be great! I'm just not sure what I'm missing.

Thanks,
Scott
Reply With Quote
Sponsored Links
  #2  
Old 3rd August 2006, 17:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Please comment out these lines in your main.cf:

Code:
smtp_sasl_local_domain =
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd August 2006, 19:32
Sarcha Sarcha is offline
Junior Member
 
Join Date: Aug 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried what you said and when I send now without authentication the maillog shows this...

Aug 3 12:15:02 ns1 postfix/smtpd[8362]: connect from unknown[10.10.10.5]
Aug 3 12:15:02 ns1 postfix/smtpd[8362]: 8C2988345F4: client=unknown[10.10.10.5]
Aug 3 12:15:02 ns1 postfix/cleanup[8363]: 8C2988345F4: message-id=<44D22104.8000903@advcomputers.ca>
Aug 3 12:15:02 ns1 postfix/qmgr[8082]: 8C2988345F4: from=<scott@advcomputers.ca>, size=522, nrcpt=1 (queue active)
Aug 3 12:15:02 ns1 postfix/smtpd[8362]: disconnect from unknown[10.10.10.5]

but the email never goes through.

There is also alot of lines like the following....

Aug 3 12:19:48 ns1 postfix/smtp[8500]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 3 12:19:48 ns1 postfix/smtp[8501]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 3 12:19:49 ns1 postfix/master[8079]: warning: process /usr/libexec/postfix/smtp pid 8500 exit status 1
Aug 3 12:19:49 ns1 postfix/master[8079]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 3 12:19:49 ns1 postfix/master[8079]: warning: process /usr/libexec/postfix/smtp pid 8501 exit status 1
Aug 3 12:19:49 ns1 postfix/master[8079]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling


Anything else I should be checking? Thanks again for helping!
Reply With Quote
  #4  
Old 4th August 2006, 14:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by Sarcha
Aug 3 12:19:48 ns1 postfix/smtp[8500]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 3 12:19:48 ns1 postfix/smtp[8501]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
I thought these messages would go with what I posted above... Anyway, I noticed a lot of directives in your main.cf that are not mentioned in the tutorial. Try to remove them.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th January 2007, 16:50
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I am also having very similar problems to this thread. My set up is running Fedora core 5 with Ispconfig v2.2.9. Installed as per howtoforge instructions.

I also can receive and send mail internally but not externally. This might be because my isp may be blocking port 25, but a few errors are showing in the mail log.

I think the problem may be because of the error.
Quote:
postfix/qmgr[1972]: fatal: specify a password table via the 'smtp_sasl_password_maps'
The file 'smtp_sasl_password_maps' dosn't exist on my system or is this something that should be set up from ispconfig.

Many thanks in advance for any help you may be able to give.

PS I am new to linux and learning very quick lol
Reply With Quote
  #6  
Old 20th January 2007, 17:30
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

My maillog file from startup

Jan 20 13:56:39 server1 dovecot: Dovecot v1.0.beta8 starting up
Jan 20 13:56:39 server1 dovecot: Generating Diffie-Hellman parameters for the first time. This may take a while..
Jan 20 13:56:39 server1 sendmail[1909]: alias database /etc/aliases rebuilt by root
Jan 20 13:56:39 server1 sendmail[1909]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jan 20 13:56:41 server1 postfix/postfix-script: starting the Postfix mail system
Jan 20 13:56:41 server1 postfix/master[1962]: daemon started -- version 2.2.8, configuration /etc/postfix
Jan 20 13:56:41 server1 postfix/qmgr[1970]: 2FB7E91E2B8: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:56:41 server1 postfix/qmgr[1970]: 07ABA91E2B9: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:56:41 server1 postfix/qmgr[1970]: 0955991E2BB: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:56:41 server1 postfix/qmgr[1970]: 90E2091E2BA: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:56:41 server1 postfix/qmgr[1970]: C3B8191E271: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:56:41 server1 postfix/qmgr[1970]: 84F2091E2B7: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:56:41 server1 postfix/qmgr[1970]: A362891E274: from=<admin@bookowl.co.uk>, size=4215, nrcpt=1 (queue active)
Jan 20 13:56:42 server1 postfix/smtp[1972]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Jan 20 13:56:43 server1 postfix/master[1962]: warning: process /usr/libexec/postfix/smtp pid 1972 exit status 1
Jan 20 13:56:43 server1 postfix/master[1962]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Jan 20 13:57:12 server1 postfix/postfix-script: stopping the Postfix mail system
Jan 20 13:57:12 server1 postfix/master[1962]: terminating on signal 15
Jan 20 13:57:12 server1 sendmail[2489]: alias database /etc/aliases rebuilt by root
Jan 20 13:57:12 server1 sendmail[2489]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jan 20 13:57:15 server1 postfix/postfix-script: starting the Postfix mail system
Jan 20 13:57:15 server1 postfix/master[2546]: daemon started -- version 2.2.8, configuration /etc/postfix
Jan 20 13:57:15 server1 postfix/qmgr[2548]: 2FB7E91E2B8: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/qmgr[2548]: 07ABA91E2B9: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/qmgr[2548]: 0955991E2BB: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/qmgr[2548]: 90E2091E2BA: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/qmgr[2548]: C3B8191E271: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/qmgr[2548]: 84F2091E2B7: from=<admin@bookowl.co.uk>, size=4213, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/qmgr[2548]: A362891E274: from=<admin@bookowl.co.uk>, size=4215, nrcpt=1 (queue active)
Jan 20 13:57:15 server1 postfix/smtp[2575]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Jan 20 13:57:16 server1 postfix/master[2546]: warning: process /usr/libexec/postfix/smtp pid 2575 exit status 1
Jan 20 13:57:16 server1 postfix/master[2546]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Jan 20 13:57:25 server1 dovecot: ssl-build-param: SSL parameters regeneration completed
Jan 20 13:58:16 server1 postfix/smtp[2885]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Jan 20 13:58:17 server1 postfix/master[2546]: warning: process /usr/libexec/postfix/smtp pid 2885 exit status 1
Jan 20 13:58:17 server1 postfix/master[2546]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling



My main.cf file


queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
efault_privs = nobody
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtp_sasl_local_domain =
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtp_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_sasl_authenticated_header = yes
tls_random_source = dev:/dev/urandom
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination

Last edited by Andee63; 20th January 2007 at 19:11.
Reply With Quote
  #7  
Old 21st January 2007, 05:41
livinginx livinginx is offline
Junior Member
 
Join Date: Jan 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Shouldn't "mydestination" be commented out?

The current problem I am working on is connecting to the SMTP server via Thunderbird. But I don't want to jack this thread. I was just comparing my main.cf to the last one posted.
Reply With Quote
  #8  
Old 21st January 2007, 16:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,994
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Please check that there is no white space in the string

Code:
reject _unauth_destination
that appears twice in the configuration file. It must be:

Code:
reject_unauth_destination
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 21st January 2007, 16:28
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Please check that there is no white space in the string

Code:
reject _unauth_destination
that appears twice in the configuration file. It must be:

Code:
reject_unauth_destination
Thanks till, Im not sure why the white space is showing, as it isnt there in the original main.cf. Must have been added when I copied it over to the forum. Just in case it was a hidden character I have deleted the text and re entered it.

Still getting the same errors
Reply With Quote
  #10  
Old 21st January 2007, 17:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the output of
Code:
postconf -d
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email box problems... slighty_sykotic Installation/Configuration 1 3rd August 2006 15:59
Relay forward all outgoing email simplyworks Installation/Configuration 3 20th July 2006 19:06
Email problems lead to apache problems natewlew Installation/Configuration 7 10th July 2006 09:53
Sending email problems: Relay access denied jaffaizal HOWTO-Related Questions 35 24th April 2006 11:04
Problems on setting new site always www on email!!! lyndros Installation/Configuration 3 14th March 2006 06:45


All times are GMT +2. The time now is 11:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.