Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th September 2012, 11:54
lazacom lazacom is offline
Junior Member
 
Join Date: Sep 2012
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix not sending mails to any outside domain except my own

Postfix is sending emails only for my domain, nemogucamisija.com. But not to gmail or any other. User however can receive emails from any mail servers (gmail, yahoo... ). Here is /var/log/maillog output:

Quote:
Sep 6 11:17:09 server02 postfix/smtpd[30377]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 6 11:17:09 server02 postfix/proxymap[30378]: error: open /etc/postfix/mysql-virtual_mailboxes.cf: No such file or directory
Sep 6 11:17:09 server02 postfix/smtpd[30377]: connect from 109-92-11-38.dynamic.isp.telekom.rs[109.92.11.38]
Sep 6 11:17:09 server02 postfix/proxymap[30378]: error: open /etc/postfix/mysql-virtual_domains.cf: No such file or directory
Sep 6 11:17:09 server02 postfix/trivial-rewrite[30380]: fatal: open dictionary: expecting "type:name" form instead of "/etc/postfix/transport"
Sep 6 11:17:10 server02 postfix/master[26436]: warning: process /usr/libexec/postfix/trivial-rewrite pid 30380 exit status 1
Sep 6 11:17:10 server02 postfix/master[26436]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling
Sep 6 11:17:18 server02 dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<office@nemogucamisija.com>, method=PLAIN, rip=109.121.92.53, lip=5.$
Sep 6 11:18:10 server02 postfix/trivial-rewrite[30390]: fatal: open dictionary: expecting "type:name" form instead of "/etc/postfix/transport"
Sep 6 11:18:11 server02 postfix/master[26436]: warning: process /usr/libexec/postfix/trivial-rewrite pid 30390 exit status 1
Sep 6 11:18:11 server02 postfix/master[26436]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling
Any idea? Thanks in advance!
Reply With Quote
Sponsored Links
  #2  
Old 6th September 2012, 12:24
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

post the output of postconf -n ... or the content of main.cf

Last edited by TiTex; 6th September 2012 at 12:31.
Reply With Quote
  #3  
Old 6th September 2012, 12:30
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

There are some config files missing.

If you use ISPConfig then download ispconfig again, unpack it and run the update.php script which is in the install folder. Choose yes when the updater asks you if the services shall be reconfigured.

If your setup is not a ispconfig server, then you might want to redo the guide that you used to setupthe server and create the missing config files manually.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 6th September 2012, 12:43
lazacom lazacom is offline
Junior Member
 
Join Date: Sep 2012
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

postconf -n

Quote:
allow_untrusted_routing = yes
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
html_directory = no
ignore_mx_lookup_error = yes
inet_protocols = ipv4
mailq_path = /usr/bin/mailq
manpage_directory = /usr/local/man
mydestination = nemogucamisija.com, localhost, localhost.nemogucamisija.com
mydomain = nemogucamisija.com
myhostname = nemogucamisija.com
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = nemogucamisija.com
newaliases_path = /usr/bin/newaliases
notify_classes = bounce, 2bounce, delay, policy, protocol, resource, software
readme_directory = no
sample_directory = /etc/postfix
sendmail_path = /usr/sbin/sendmail
setgid_group = postdrop
smtpd_tls_security_level = none
transport_maps = /etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_uid_maps = static:5000
Yes, I have tried ISPConfig, but it could not install, so i decided not to go ISPConfig route. I instead installed webmin+virtualmin.
Reply With Quote
  #5  
Old 6th September 2012, 12:44
lazacom lazacom is offline
Junior Member
 
Join Date: Sep 2012
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

And yes, this is postfix 2.9.4 on Ceont0s 6 x86_64, built from source (as root). Had to remove 2.6 cause of ISPConfig ...
Reply With Quote
  #6  
Old 6th September 2012, 12:54
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

if i'm not mistaken
Quote:
transport_maps = /etc/postfix/transport
should be
Code:
transport_maps = hash:/etc/postfix/transport
but first run this command
Code:
postmap /etc/postfix/transport
and then restart postfix
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 10:56
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail-Problema jz_ HOWTO-Related Questions 9 14th September 2011 13:31
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
sneaking suspicion my postfix config has gone awry mjbarfoot Installation/Configuration 7 24th August 2010 12:23
Need help get mail to work (can't recieve and apperently can't send) omega13a Installation/Configuration 19 20th August 2009 21:06


All times are GMT +2. The time now is 18:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.