Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th September 2012, 21:23
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default Disabled Websites - Redirected

Hello and good afternoon.

I recently disabled some websites but noticed the sites are being redirected to other websites that I am hosting.

Not quite sure why this is happening.

Background: I am running openSUSE 11.0, using dynamic DNS, dns is configured with the Dynamic DNS Hosting service, some ISPConfig sites are configured with DNS Zones (via ISPConfig) while others are not (does this matter)?

Any help would be much appreciated.

Thanks!
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
Sponsored Links
  #2  
Old 6th September 2012, 09:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Apache shows the first vhost in alphabetical order for a IP address if there is no vhsot for a given domain. So what you describe is the normal behaviour of the apache webserver when it does not find a site because you disabled it.

To redirect the requests to a specific site, you have to create a default vhost that catches these requests.

Create a new website with this domain name:

000default.tld

and select the IP address that it shall work for (the Ip that the other sites use). Now all requests of disabled sites will go to this vhost instead of a vhost of a different customer.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th September 2012, 23:26
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default Disabled Websites - Redirected

Works!

Thanks a bunch!!
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Websites page missing websites (after update) a0011010011 General 1 18th January 2012 15:12
Need help with ISPConfig 3 Update midcarolina Installation/Configuration 36 8th November 2011 22:07
Problem with ispconfig 3 staff007 Installation/Configuration 4 10th October 2011 21:17
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
colocation problem d3m0nic Installation/Configuration 14 23rd June 2006 23:18


All times are GMT +2. The time now is 21:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.