Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd September 2012, 12:41
lazacom lazacom is offline
Junior Member
 
Join Date: Sep 2012
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Bizare postfix problems with file ownership

I had problem with non working postfix server (after unsucessfuly completed ISPConfig installation) and I solved it with removing it (yum remove postfix) and installing it from source (postfix 2.9.4, built as root).

I had to install 2.7 or newer because virtualmin forced me. After that, mail server started to send test email and could get it.

But, after that, I noticed that I can receive outside emails but can not send mails to any other domain (only to other emails on my domain, nemogucamisija.com). Error code was:
Quote:
Out: 220 nemogucamisija.com ESMTP Postfix
In: EHLO mail-bk0-f46.google.com
Out: 250-nemogucamisija.com
Out: 250-PIPELINING
Out: 250-SIZE 10240000
Out: 250-VRFY
Out: 250-ETRN
Out: 250-STARTTLS
Out: 250-AUTH PLAIN LOGIN
Out: 250-AUTH=PLAIN LOGIN
Out: 250-ENHANCEDSTATUSCODES
Out: 250-8BITMIME
Out: 250 DSN
In: STARTTLS
Out: 454 4.7.0 TLS not available due to local problem
In: QUIT
Out: 221 2.0.0 Bye
Then I noticed that postfix can not access certificate. Disabled TLS but now I can not set Transport Mapping, cause postfix can not access /etc/postfix/transport . Tried
Quote:
chown postfixostfix /etc/postfix/transport
chmod 777 /etc/postfix/transport
and
Quote:
postmap /etc/postfix/transport
postmap: fatal: open database /etc/postfix/transport.db: Permission denied
I know building it as a root was not smartest idea, but tutorial required it. So, what I shoul do to fix this? Or, any other solution to enable sending emails to other domains than my own?

Thanks in advance!
Reply With Quote
Sponsored Links
  #2  
Old 3rd September 2012, 12:48
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

what about /etc/postfix/ dir permisions ?

ls -ld /etc/postfix/
Reply With Quote
  #3  
Old 3rd September 2012, 12:50
lazacom lazacom is offline
Junior Member
 
Join Date: Sep 2012
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

drwxr-xr-x 2 root root 4096 Sep 3 11:22 /etc/postfix/
Reply With Quote
  #4  
Old 3rd September 2012, 13:20
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

that's ok ... postfix would have read privileges
so it must be something else wrong , did you check the other files permisions ?

i would suggest recreating the certificate http://postfix.state-of-mind.de/patr...s_support.html

ls -l /etc/postfix/

Last edited by TiTex; 3rd September 2012 at 13:27.
Reply With Quote
  #5  
Old 3rd September 2012, 15:01
lazacom lazacom is offline
Junior Member
 
Join Date: Sep 2012
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, will do it, but my main problem is no more TLS support, but to enable postfix to send emails outside my domain. Do you have some solution for that? It seems that without transport mapping I can't do that.

And I can't make postfix access those files (/etc/postfix/transport), it keeps telling me:
Quote:
Error while saving a mapping : No map file defined
Reply With Quote
  #6  
Old 3rd September 2012, 15:28
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

that is very abstract , you should better check /var/log/maillog for more informations upon what's wrong.
also if you followed a HowTo , you should post the link but first dublechek it ... maybe you've missed something in your configuration.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mail authentication failure - unknown user or password evok Installation/Configuration 9 16th October 2010 06:37
I can't finish install due a problem Sam9999 Installation/Configuration 7 17th September 2010 22:33
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
rewrite url not work apache2+mod_rewrite mohamedtah Installation/Configuration 1 31st January 2009 13:00
add web site serr57 Installation/Configuration 18 13th April 2008 11:40


All times are GMT +2. The time now is 12:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.