#1  
Old 31st August 2012, 15:20
maxeaves maxeaves is offline
Junior Member
 
Join Date: Feb 2011
Location: London, United Kingdom
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default amavisd problems

Hello Falko and team,

Sorry to bother you, but ISPConfig 3.0.4.6 is giving me problems. I'm running Centos 6.3 with the Nginx build - built using the instructions online, and I'm strugging to get the system to place ball.

Amavisd is being a pain, and won't connect to local database. I'm getting the following error messages:

Aug 29 05:27:47 vps amavis[10929]: (10929-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;por t=3306': Can't connect to MySQL server on '127.0.0.1' (13)
Aug 29 05:27:47 vps amavis[10929]: (10929-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 88) line 241, <GEN15> line 4.

Usual stuff...amavisd is running, as is postfix...and they have been restarted without problems....I assume that clamd-amavisd is a child daemon that runs off amavisd....

I've checked the username/password on ispconfig on the mysql database, and it all seems to work, so I'm wondering why Amavisd is not playing ball..

Thanks


Max
Reply With Quote
Sponsored Links
  #2  
Old 1st September 2012, 08:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

What's the output of
Code:
netstat -tap
?

Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing LAMP - MySQL and PHP5 JosBR Server Operation 5 19th December 2009 21:00
Courierr Errors were encountered while processing AsDsL General 1 30th November 2009 08:03
E: Sub-process /usr/bin/dpkg returned an error code (1) ergti Installation/Configuration 1 16th August 2009 12:36
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Empty Recycle Bin jon335 General 40 6th May 2006 11:56


All times are GMT +2. The time now is 15:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.