Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th August 2012, 16:02
mcc28x mcc28x is offline
Junior Member
 
Join Date: Sep 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy phpvirtualbox tutorial - problem

Hi,

I have followed the tutorial http://www.howtoforge.com/managing-a...x-ubuntu-12.04 but have an error when I try to login at myserver/phpvirtualbox/

I use the default username/password (admin/admin) but ge tthe following error message:

Code:
Exception Object
(
    [message:protected] => Error logging in to vboxwebsrv.
    [string:Exception:private] => 
    [code:protected] => 64
    [file:protected] => /var/www/phpvirtualbox/lib/vboxconnector.php
    [line:protected] => 188
    [trace:Exception:private] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/phpvirtualbox/lib/auth/Builtin.php
                    [line] => 45
                    [function] => connect
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                        )

                )

            [1] => Array
                (
                    [file] => /var/www/phpvirtualbox/lib/ajax.php
                    [line] => 119
                    [function] => login
                    [class] => phpvbAuthBuiltin
                    [type] => ->
                    [args] => Array
                        (
                            [0] => admin
                            [1] => admin
                        )

                )

        )

    [previous:Exception:private] => 
)
The only information in the logfile is:
Code:
VirtualBox web service 4.1.18 r78361 linux.amd64 (Jun 20 2012 14:50:49) release log
00:00:00.000 main     Log opened 2012-08-17T12:52:51.706645000Z
00:00:00.000 main     OS Product: Linux
00:00:00.000 main     OS Release: 3.2.0-29-generic
00:00:00.000 main     OS Version: #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012
00:00:00.000 main     OS Service Pack: #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012
00:00:00.000 main     Executable: /usr/lib/virtualbox/vboxwebsrv
00:00:00.000 main     Process ID: 3993
00:00:00.000 main     Package type: LINUX_64BITS_UBUNTU_12_04
/var/log/vboxweb.log (END)
There are some threads on the web about this error but none of them particularly conclusive. Anyone help me resolve this please?

regards

Mark
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2012, 21:52
mcc28x mcc28x is offline
Junior Member
 
Join Date: Sep 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default

I solved this by logging in as user vbox and issuing
Code:
 VBoxManage setproperty websrvauthlibrary null
Reply With Quote
The Following User Says Thank You to mcc28x For This Useful Post:
falko (18th August 2012)
Reply

Bookmarks

Tags
phpvirtualbox, ubuntu 12.04

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Courier Imap is not working HellMind General 5 12th April 2012 02:04
Mail send/recieve problem DKLeader Installation/Configuration 14 22nd February 2011 16:13
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Problem with your FaceBook Tutorial pclark Programming/Scripts 1 2nd December 2008 15:55
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 17:52


All times are GMT +2. The time now is 09:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.