Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th July 2012, 07:25
norbie norbie is offline
Junior Member
 
Join Date: Jul 2012
Posts: 22
Thanks: 5
Thanked 2 Times in 2 Posts
Post ISPConfig monitor System Log

Thought I'll open this thread, because I think there is a wrong config variable or? for the syslog log.

On an Ubuntu system 12.04 Server LTS the "system" log is not called "messages" instead they use "syslog"

I might be wrong however once I retrieve the system log file, an error is thrown.
Quote:
"Unable to read /var/log/messages"
Dunno if this is fixed pointer or if it can be configured to point to /var/log/syslog ?

Just thought I post my thoughts.

Cheers,
Norbert
Reply With Quote
The Following User Says Thank You to norbie For This Useful Post:
pyrjjiatolr (10th November 2012)
Sponsored Links
  #2  
Old 28th July 2012, 10:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I've added this to our bugtracker, so we will check that.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
teencelom (1st August 2012)
  #3  
Old 2nd November 2012, 17:58
mmidgett mmidgett is offline
Senior Member
 
Join Date: Aug 2006
Location: Mooresville, North Carolina - USA
Posts: 112
Thanks: 5
Thanked 14 Times in 13 Posts
Default

If you have a server like I have and it doesn't work you can make a link and it will work just fine

sudo ln -s /var/log/syslsog /var/log/messages

sudo chown syslog:adm /var/log/messages

This is fix the monitor in Ispconfig3 using ubuntu 12.04LTS and Ver 3.0.4.6
Reply With Quote
The Following User Says Thank You to mmidgett For This Useful Post:
norbie (5th November 2012)
  #4  
Old 5th November 2012, 04:15
norbie norbie is offline
Junior Member
 
Join Date: Jul 2012
Posts: 22
Thanks: 5
Thanked 2 Times in 2 Posts
Thumbs up Sym Link works

Hi mmidgett,
the work around works fine for my setup.
Could have been my idea , but it wasn't!!!

Thanks,
Norbert
Reply With Quote
  #5  
Old 5th November 2012, 13:43
mmidgett mmidgett is offline
Senior Member
 
Join Date: Aug 2006
Location: Mooresville, North Carolina - USA
Posts: 112
Thanks: 5
Thanked 14 Times in 13 Posts
Default

I just noticed that syslog must have rotated the log cause the link Is now broken. I wouldnt do my recomendation unless you scripy the deleting of the old links and create new ones. I think It would be better to look through the code and find where it calls it and change it. I will look for It today and post my findings.
Reply With Quote
  #6  
Old 5th November 2012, 21:55
norbie norbie is offline
Junior Member
 
Join Date: Jul 2012
Posts: 22
Thanks: 5
Thanked 2 Times in 2 Posts
Default Not a big deal!

Hi mmidgett,
it's really not a big deal, I can always SSH and read the Syslog directly.

Just had a look at the Monitor within the ISPConfig panel and it still looks alright.
I don't know how often Logrotate does create new logfiles?
Perhaps my system didn't get to that point yet or logrotate isn't involved as much?

On the other hand it seems to be weird that logrotate would break the link.
How does logrotate create new logs, hmmm. Think it stops logging, then renames the old logfiles, if older tar balls them, then creates a new logfile with the name given in /usr/local/ispconfig/server ( sorry just looked at it, this is varable (PHP) so it sits deeper).
I got lost!!! Just finding the relevant part of it is a challenge.

Cheers, and TNX,
Norbert
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
Apache log rotation not configured in ISPConfig 3? gkovacs Installation/Configuration 17 20th February 2011 23:29
ISPconfig 3: can't send or receive messages zogthegreat Installation/Configuration 6 22nd May 2010 14:45
ISPconfig log files in /var/log todvard Installation/Configuration 4 3rd May 2010 19:07
Can't Log in to existing ispconfig system bergkamp(10) General 7 10th August 2008 11:57


All times are GMT +2. The time now is 18:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.