Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th July 2012, 21:58
awado awado is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Thanks: 1
Thanked 2 Times in 1 Post
Default amavis - "clamd.sock: No such file or directory"

Hello world!

For the last 12 hours I was digging deep into Google results to get a tricky bug out of my freshly installed ISPC on Centos 6: amavis always reported a fatal error when trying to scan an incoming mail.

amavis[4260]: (04260-02) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/spool/amavisd/clamd.sock (Can't connect to UNIX socket /var/spool/amavisd/clamd.sock: No such file or directory) at (eval 90) line 373.\n

It seems to be a problem for a lot of people. Several Google results advised to change the path so clamd.sock in the amavisd.conf and clamd.conf. But nothing helped. But as the spool folder is only a temporary folder, its content must be created somehow at the startup of some service. That pointed me to the right direction:

chkconfig clamd.amavisd on

It starts clamd for amavisd at boot time and therefore creates the clamd.sock, so it can be accessed. Maybe it saves someone else's day...
Reply With Quote
The Following 2 Users Say Thank You to awado For This Useful Post:
falko (26th July 2012), till (26th July 2012)
Sponsored Links
Reply

Bookmarks

Tags
amavis, clamav, clamd, clamd.sock

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Combination of postfix and courier failing Xaymar Server Operation 3 7th March 2012 17:28
rkhunter warnings esezako General 7 27th September 2011 07:28
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 15:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.